Question BIOS can't find Boot SSD after "Critical Process Died" error ?

Aug 18, 2022
1
0
10
0
PC Specs:
CPU: Intel i5 7400
GPU: Zotac GTX 1050ti
Motherboard: Gigabyte GA-H110M-H
RAM: 16GB DDR4 Corsair Vengeance RGB PRO 3200MHz (running at 2400MHz due to CPU limitation)
500W PSU
SSD: Was running Kingston 240gb A400
Changed it out to a Samsung 1tb 870 QVO as i thought the ssd was the problem.
OS: Windows 10

I got the machine late 2017, changed the RAM around mid 2020 and added the Kingston SSD around mid 2019.

I was using my pc once when suddenly my pc fully locked up and blue screened, coming up with the error "Critical Process Died". After that i was unable to boot into windows as not even my BIOS could recognise that my SSD was connected. I was running one ssd and one hdd, the ssd being the boot drive and hdd being the place where i stored my games etc. Both drives were very low on remaining space so i initially thought that due to the low space windows had become corrupt. Before anything else I changed SATA and power cables for the ssd, used different ports on the motherboard, still with no luck, tried booting with only the ssd plugged in, still wouldnt recognise that it was there. Under SATA Configuration in BIOS all it would say for SATA 0, 1, 2 and 3 was NOT INSTALLED.

I then took the SSD to another Windows 10 machine to reformat it. This machine recognised it fine and all files on the drive were fine. I did not try to boot from this drive on the other machine. I formatted the drive, and created a partition. I then took the SSD back to my pc, it still wouldnt recognise it. I gave up for the day and tried again the following morning, where my pc was able to recognise it, and i was able to reinstall a fresh copy of windows onto the ssd from a usb installation media i had created.

My pc was then running fine for about 2 hours, with me reinstalling apps and also managed to play some games for a while until again it suddenly locked up and blue screened with Critical Process Died. After doing more research, i thought that because i had run the pc with such little free space before (im talking like 7-8GB left) i had damaged the ssd. I then went out and bought the Samsung 1tb 870QVO. I formatted it on the other machine before and created a partition table etc, took it to my pc and it wouldnt recognise it for a while. Suddenly it did recognise it and i was able to install windows again on here and all was fine. I was able to use the machine for about another 2 hours, before again it locked up and said critical process died.

I ran all the sfc scannow, chkdsk etc when i was able to boot into windows, however now that i cant boot as my pc cant recognise that the ssd is there i am unable to do anything like that. Cant even do Safe Mode.

I've been thinking whether i need to update the BIOS on my motherboard, however am yet to do so. I am also unable to go back to a previous image as none have been stored.

Anyone else had this problem? If so how did you fix it?

Thanks alot
 

ASK THE COMMUNITY