Question BIOS corruption?

Apr 16, 2021
1
0
10
0
So Yesterday I got a new laptop which is "Lenovo". It was working normally. I installed one game, and then I got a pop up to download BIOS, so I thought "if it was a pop up I needed to click download", so I did. After a bit of time it restarted the computer and it showed like a cmd thing. But I think it went corrupt or didn't install correctly. I just left it alone for 20 minutes and when got back it was turned off. I tried to turn it on, but it showed blank screen, not even showing the logo of the laptop.

Off/on button is being lightened, but nothing works, nor trying to lower the volume, nor trying to go into BIOS or even not going in safe mode. So there's a "Novo Button", which should recover the pc if it fails to boot normally, but even that does not work. Any keywords or combinations are useless as they do nothing. As for the battery, it's not removable.

As for the solution I can only think of:

Laptop fails to connect to display.
Hardware failure / which is not so much likely.
Motherboard fails to connect to something.

I'm not really good of a English speaker, so I'm really sorry if you don't understand, I'll try to explain my sentences if they do not make sense. I'm not a good Laptop or computer specialist either, so I really need someone's help.

Should I just seek help where I bought it? Any solutions are appreciated!

The version I tried to download of BIOS was BIOS 5, as I remember.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS