Question BIOS doesn't detect SSD's

Jan 26, 2021
1
0
10
0
Hello everyone,

My system:
  • Intel Core i7 8700K
  • MSI Z370 SLI Plus
  • EVGA GTX 1070 FTW Gaming
  • 16GB Corsair Vengeance RAM
  • Corsair RM750X PSU
  • 2x Samsung EVO 500GB (2,5" SATA)
  • 2x WD HDD
Yesterday I ran a fresh install of Windows 10 but I kept getting blue screens (I know the stable OC configs of both CPU & GPU) when I tried to overclock both my GPU and CPU at the same time. I concluded that I probably needed a bigger PSU (I used to have a 520watt PSU) so I ordered the Corsair RM750X PSU. I decided to undo the CPU overclock and install some stuff overnight (COD Warzone). The system was fully stable at this time.

Upon receiving the PSU I swapped out the old one and installed the Corsair one, all good so far. However, I tried connecting both of my SSD’s (Windows is installed on one of them) but they aren’t showing up in the BIOS. When I pull the data and power cable out of the SSD and plug them in one of the HDD’s the HDD DOES show up (so know I know the problem isn’t a faulty data or power cable!) While swapping the PSU I did wear an antistatic bracelet so I highly doubt that BOTH my SSD’s died..

I did google for some solutions because I was suspecting it having something to do with BIOS settings. So far I have tried multiple BIOS settings based upon multiple forums but nothing has worked.

Can anyone help me out? Are both my SSD’s dead? :(

edit: I already did update the BIOS to the latest version.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS