Question BIOS Flash successful - No longer booting

Jun 16, 2019
3
1
15
0
Hi all,

Just looking for a bit of advise here.
I flashed by BIOS earlier today using the USB stick at BIOS screen method, which has worked for this MB before.
However after a successful message on the flash, my machine requested a reboot. Since then all that happens is it powers on for about 10 seconds, nothing on the screen, no HDD activity light, then turns itself off and back on again, the cycle repeats.

I've tried clearing the CMOS with a paper clip and the jumpers, also battery removal for 30 minutes. No difference.

Ive removed RAM tested. Nothing
I've removed GPU tested. Nothing

Any help would be appreciated.

System spec:
Ryzen 2700
AsRock steel legend b450M mobo
16gb corsair vengeance 3000mhz
Rx580 nitro+

One thing to add, it was only after that I realised that the USB stick I was using was formatted in NTFS rather than FAT32, but it still gave a successful message prior to the reboot.

Thanks all.
 
Jun 16, 2019
3
1
15
0
Just an update - I've been messing around with it all day and have finally found what 'could' be the issue.
I stated that I removed the RAM and nothing - That was true, what I didn't do however was remove one stick at a time.
I removed the first stick - Boom! We're working again. Took the working stick out and put the 'faulty' one back in on a different port. Didn't work.
So that shows me that this particular mem module doesn't like to work.

What this doesn't tell me however is:
  • What caused it to go in the first place
  • Is it the memory module that's faulty or is it after the BIOS update that my Mobo now doesn't like dual channel configurations
  • Could my PSU still be faulty as this was something I thought about previously, as I've had some symptoms
 
Jun 16, 2019
3
1
15
0
I'd make sure the BIOS is set to optimized defaults, save and exit and then install both RAM modules (in slots A2 and B2 as stated in your MB Manual on page 22) and see if it will boot.
If it does run Memtest86+ and see if it finds any errors on either RAM stick.
100% wouldn't boot with this particular memory module installed. Unable to run MemTest.

Going to take that as the culprit for now I think. I've got new modules coming tomorrow so should have a comparison for the dual channel stuff tomorrow.
 
Reactions: DMAN999

ASK THE COMMUNITY