Question BIOS issues with older Asus P8H67-M Pro ?

Sep 24, 2021
7
0
10
0
Just spent the last few hours trying to update the bios on this board from a jump start with the update from the Ausu website.... fun! Ausu showed the latest bios being 3904 for this board and I was installing from a flash drive. I keep getting the message "image integrity check failed". Long story short on the board it also has CM 6850 which takes the latest bios 1301 the 1301 popped right in. Now for the question does anyone know if the I5 3570K will work in this board with the 1301 bios? I looked but can't find it.
 
Just spent the last few hours trying to update the bios on this board from a jump start with the update from the Ausu website.... fun! Ausu showed the latest bios being 3904 for this board and I was installing from a flash drive. I keep getting the message "image integrity check failed". Long story short on the board it also has CM 6850 which takes the latest bios 1301 the 1301 popped right in. Now for the question does anyone know if the I5 3570K will work in this board with the 1301 bios? I looked but can't find it.
you could try this flashing method if it doesn't work
https://linustechtips.com/topic/592133-howto-get-nvme-support-on-older-motherboards/ (just do it with your normal bios, no modded bios needed)
 
Sep 24, 2021
7
0
10
0
Thank you for the help. I was able to install the latest version of the bios onto the Asus P8H67-M Pro motherboard version 1301 and get the board to boot. I got hold of a I5 3570K CPU ( eBay special) that should be here next week just not sure if it's going to work on the board. Thank you again for the information you gave me.
 
I got hold of a I5 3570K CPU ( eBay special) that should be here next week just not sure if it's going to work on the board.
either get 3570k or E3 1240 v2 if you have gpu (if prices differences is little)

Thank you for the help. I was able to install the latest version of the bios onto the Asus P8H67-M Pro motherboard version 1301 and get the board to boot.
Yeah, it's just sometimes old asus board get some errors like this :D
 
Sep 24, 2021
7
0
10
0
Sep 24, 2021
7
0
10
0
Well got the CPU today I5 3570K and installed it on that board. I reset the COMS before I installed the CPU. Fan just turns off for a second and then on it booted once to BIOS and I set the time and date, but that was it. Won't boot anymore I can boot with the second gen I3. BIOS issue or I5 issue not sure anyway to tell?
 

ASK THE COMMUNITY