• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Bios keeps putting the m.2 ssd as the highest boot priority

Jul 3, 2020
3
0
10
0
Dear people at Tom's hardware,

I've had an issue with booting my pc up for a while now. I have an Aorus Elite b450 and the bios of this motherboard is what confuses me. I haven't had this issue before but ever since we swapped the motherboard to a new case and swapped out the CMOS battery, my bios keeps changing the boot priority. Instead of my windows ssd, it keeps wanting to boot from my m.2 ssd which doesnt have any windows on it. I double checked this by completely formatting it, removing its partitions and giving it a new partition. But it still keeps wanting to boot from my m.2. I originally thought it had something to do with a faulty CMOS, however the bios does remember the date and time so it is not like that has been getting reset every time. It seems to be that my bios keeps intentionally trying to move the m.2 to the top of the boot priority list. Is anyone familiar with this or does anyone please have an idea of what is going on?
 
Jul 3, 2020
3
0
10
0
Disable every other boot device in the bios.
Thank you, this fixed the issue I had of my m.2 getting the prio every time. However, now I am puzzled by yet another thing. My pc just straight up doesnt recognize my bootdrive sometimes when I boot it up, it has no issues once it has been booted up however and I have been using it for the longest time like this without this issue. Once it decides it wont boot, I only have to reboot my system to get it back though. Any idea as to what could cause this? I don't think it is a bad sata cable or power since it does work fine when my pc is running, I only have this issue at bootup
 
Thank you, this fixed the issue I had of my m.2 getting the prio every time. However, now I am puzzled by yet another thing. My pc just straight up doesnt recognize my bootdrive sometimes when I boot it up, it has no issues once it has been booted up however and I have been using it for the longest time like this without this issue. Once it decides it wont boot, I only have to reboot my system to get it back though. Any idea as to what could cause this? I don't think it is a bad sata cable or power since it does work fine when my pc is running, I only have this issue at bootup
Maybe you just need the latest BIOS update. What is your CPU?
 
Jul 3, 2020
3
0
10
0
My CPU is the ryzen 2600, I am not certain if it is a BIOS update though but I could always try though since it's not 3rd gen ryzen, I am not sure whether it matters too mcuh
 

ASK THE COMMUNITY

TRENDING THREADS