Question BIOS not detecting NVME

arbiterrecon

Reputable
Aug 13, 2016
167
0
4,680
0
Intel NVME 660p 1tb
Asus Strix 450-b gaming

I fully updated my bios and chipset, I have tried 2 m.2 slots, I have tried in ACHI and RAID modes.

I have been trying for 3 days to install windows to NVME, I have used Rufus (both MBR and GPT) and windows creation tool.

I heard NVME will only do GPT so I have been mostly doing that. I have disabled CSM and secure boot, install windows 10 on the NVME but the issue I am having is my BIOS will only detect my NVME if I have legacy mode on.

If I use UEFI mode only then my NVME will disappear from boot selection, I have tried secure boot windows UEFI mode too but the NVME will only show if legacy is enabled.

I have a windows 10 install working on HDD and I made sure NVME was GPT partition and it even has EFI boot sector of 300MB but when I go to boot with it in legacy mode it just black screens and says need boot media. Using UEFI mode only and the NVME just wont show at all so it goes back to BIOS on boot.

Any help would be great
 

ASK THE COMMUNITY