Bios not recognizing CD-ROM



I am building a new system described in the How To section of this web site. Everything is going well, but I cannot get the bios to recognize the presence of a CD-ROM.

A7B mobo
Hard Drive on primary IDE as master
CD-ROM on secondary IDE as master
both of these on the Ultra DMA/66 IDE connectors
300W power supply (so power isn't a prob)

In the BIOS they are all set up as auto detect. The hard drive is detected great, but even if I change the bios to look for a CD-ROM on the secondary master, it still doesn't detect it.

I have been able to format the hard drive but cannot install windows until I get the CD-ROM working. The CD-ROM is a generic Liton 52X and the CD-ROM device drivers I'm using cannot detect the CD-ROM either.


Jan 31, 2001
First of all, if your mobo doesn't POST the device, the device drivers won't do you any good. Secondly, unless you're using DOS, you shouldn't need any device drivers for a CDROM drive. I know your frustrated, but keep a level head. :)

If your CDROM is jumpered as "Cable Select", try setting it to master (if it is on its own controller). If you still don't get it to POST, try placing it on your Primary IDE controller, however jumper it as the slave device. If this works, then its likely that you have a bad secondary IDE controller.

Good luck, I hope this helps.

Joshua Van Berkum


Thanks. I pulled the CD-ROM and put it in another computer to make sure it functions (and it worked fine). Then I re-installed it into the original computer on the secondary IDE (jumpered as master) and it worked. I must have been a problem with the cables not being completely seeded.

But, then I couldn't access my A: drive. Wierd huh? Then I discovered that the A: drive was accessible as B: drive. (I think A: was somehow used for a RAM drive because a DIR brought up an emergency boot floppy contents from prior uses). I checked the BIOS and didn't have the A/B swapped, and couldn't see any other wierdness there.

Since I had access to the CD-ROM finally. I reformatted the hard drive and was able to install an OS. Wheh! Now I get to tackle software driver problems! Yea!