Question Bios not working with DisplayPort

Aug 13, 2020
2
2
15
0
Hi all.

I recently upgraded my system with a new CPU and motherboard, and spent hours trying to work out why it wouldn't initially post. Turns out it simply didn't like being connected to DisplayPort. Once I switched to a DVI connection only it worked just fine. Once I got into Windows and got things set up, it recognised the DisplayPort just fine, but still won't let me go into bios with it. Whenever I turn on the PC, the screen is completely blank until I get to the windows login screen. If I want to get to the bios I have to unplug the DisplayPort cable, which can get pretty annoying. Oh and if I switch the primary monitor to an HDMI connection instead of DisplayPort it works just fine in the bios.

Is there a fix to this or is it a "wait until a bios update comes in" type of deal.

My current PC specs:
  • Motherboard: MSI B550-A Pro
  • CPU: Ryzen 5 3600 (at stock)
  • GPU: Gigabyte GTX 1060 (6GB)
  • RAM: Corsair Vengeance 3200Mhz 16GB (2X8)
  • Boot Drive: Kingston A2000 m.2 NVME Drive (250GB)
  • Primary monitor: LG 27GL83A (displayport)
  • Secondary monitor: BenQ GL2450HM (DVI)
Oh and things I've already checked/tried:
  • bios is set to UEFI mode
  • all drivers are updated
  • swapping to a different DisplayPort cable
  • cmos
  • bios update
  • reset monitor to default settings
  • all monitors are plugged into the graphics card
  • monitor worked perfectly fine with old CPU/motherboard
 
Last edited:
Reactions: brryronnie
Aug 13, 2020
15
2
15
0
I've seen similar, but on HDMI
how I solved it: I had a 2nd monitor with DVI connections, removed the HDMI, powered on with the DVI monitor, after it went to Windows I plugged in the HDMI monitor and set it to primary then I shut down the PC and removed the DVI monitor

I have no idea what causes it
my guess is that the video card defaults to a predetermined output
 

ASK THE COMMUNITY