Question BIOS only loads without boot-USB and by switching PCI slot

zambalus

Prominent
Dec 15, 2018
1
0
510
0
Hi,
here‘s the problem:
I have the new AMD Ryzen 5800x on a MSI x570 unify motherboard. First time booting up, there wasn‘t any POST screen, but I wasn‘t all too worried as I hadn‘t updated the BIOS firmware. So I did that by using an USB and flashing the BIOS directly. After that, it worked like a charm. I booted into the BIOS several times but I also was careful not to turn my system on and off every 10 sec. I have my win10 installer on an USB but I had it plugged in on the top of my tower and wanted to connect it to a port directly on the motherboard (some dude said it should be done like that and as I didn‘t have a problem getting into the BIOS I didn‘t think twice about it). However, after that nothing was being displayed on the screen. I didn‘t change anything else besides plugging the USB into a different port.

Here‘s what I tried then:
  • clearing CMOS via jumper
  • clearing CMOS via CLEAR CMOS button
  • clearing CMOS via removing battery
  • flashing BIOS again with latest firmware
  • unplugging PSU, waiting for a bit and then trying again
I then tried plugging the GPU into a different PCI slot and after that it worked! However, as soon as I plug in the USB (no matter if directly on the motherboard or on top of the case) it no longer shows anything, even after unplugging the USB. When I switch the PCI slot twice, it works again (even after restart) but only as long as I don‘t plug in the USB. I checked the USB and it seems fine, also considering that it worked the first time around. This is so weird.

I‘m thankful for any help or ideas.

UPDATE: so if I take out the GPU but then put it back into the same PCI slot again and start the PC it boots into the BIOS, but only once now, even without the USB. It doesn‘t work if I just unplug the power and hold the power button for 30s.

UPDATE: it does work if I also unplug the power connector on the GPU. Maybe this has something to do with the boot order?
 
Last edited:

ASK THE COMMUNITY