Question BIOS/POST/Boot device LED shenanigans

Nov 10, 2022
2
0
10
0
If anyone has some unique insights on my conundrum, it would be appreciated.

I took a PC tower that had been in storage for about a year. Gathered a good amount of dust. Cleaned it out and turned it on.

Here's what's happening: I turn it on, everything seems to start fine. It's going through POST but the moment it's supposed to reach my boot device LED, it actually shuts OFF. Then it turns itself ON again, goes through the steps again, and gets stuck on boot device LED and stays ON. Black screen/no signal the entire time.

So yes, clearly it's not reading a boot device. But I feel the issue is more complicated because I'm still meant to get some type of signal on my monitor and have access to BIOS?

Things I've tried:

• Tested the monitor. It works fine. That's not the issue.

• Reseated RAM and GPU. Same result.

• Tried 1 RAM stick only. Same result.

• Replaced CMOS battery with a new one. Same result.

• Cleared RTC RAM by changing the jumpers. (motherboard manual told me how to). No result.

• Made a windows USB boot stick. Absolutely no result.

• Pressed the DirectKey on the motherboard to boot straight into BIOS. It restarts, but then does the same thing as described above.

• Unplugged my SSD and HDD so that it hopefully would just go into BIOS. Nada.



My specs I'm not entirely sure on everything. It's been a long time since I looked into it and I can't start up the PC to check. The only information I have I can read on the outside:

• Corsair PSU RM850 (older model 75-001938)

• Asus Sabertooth Z89

• Geforce GTX 760

• 2x 8GB Corsair RAM

• 1 Samsung SSD

• 1 regular harddrive which I can't read the info on atm. If it really matters I'll unscrew it.

This set up used to work perfectly fine! So something got borked, but I'm out of ideas. Any help appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS