Apr 7, 2020
2
0
10
0
Good evening members, this is my first post so I hope I do things right.
I have a custom pc that I’ve been using for several years with an i7 4790k and a Gigabyte GA-Z97X-UD5H Rev. 1.0 I’ve never had problems before until recently that I installed an M2 SSD on the motherboard. Things were still fine but I would get random blue screens every now and then which I thought is normal since my PC would restart and boot up fine.
Around 3 weeks ago I woke up in the morning and turned on my PC but it wasn’t posting at all on the main bios. So I switched to the backup bios and it worked fine so I tried updating the bios even though I already had the latest firmware to try to get my main bios working again but nothing worked so i just kept using the backup bios until I can find a solution for the main bios. The backup bios was working fine until about 2 days ago where it started not posting again. So now I have a main bios and a backup bios which aren’t posting. Any solutions? Is my motherboard fried?
(the motherboard has switches on it to switch from main and backup bios. Also the motherboard has an LED display on it to display error messages and it’s just flickering through a bunch of error codes I can’t even get a good look at them)

edit: I’ve also tried to clear cmos and changed the battery on the motherboard, I’ve tried removing the GPU and the drives as well but it didn’t work out.

Thank you all, it would be great help to assist me or even point me in the right direction!
 

ASK THE COMMUNITY