BIOS resets after complete power off

rayanbaydoun234

Honorable
Sep 14, 2012
16
0
10,520
1
Hello everyone!
I recently replaced my old corsair cx 750 with a thermaltake toughpower 750M psu. Being new to modular psu’s i installed the motherbaord 24 pin cable incorrectly from the psu side , connecting only 1 of 2 plugs that should be in the psu.
After 2 failed atempts to start my pc (psu was on but the motherboard wouldnt turn on) i realized my mistake and rectified it. Now the pc works normally except that the BIOS resets after completley shutting down my pc and disconnecting it from power (detaching psu power cable from power outlet).
Edit: to describe its behaviour , after booting from a complete power off (having no electrical power), the pc turns on then off , then on again with reset bios.
If i shut down and keep power alive , this doesnt happen.
 
If the pc worked properly before, I find it unlikely that the cr2032 battery should fail after the psu change.
It is cheap to replace the battery, but they usually last a large number of years.


Why did you change out your corsair 750w psu for another one of equal capacity?


Were you having a problem with it?
 

R_K

Reputable
Jul 22, 2014
52
1
4,545
1
Hello everyone!
Edit: to describe its behaviour , after booting from a complete power off (having no electrical power), the pc turns on then off , then on again with reset bios.
If i shut down and keep power alive , this doesnt happen.
This what happening to my PC also, changed CMOS battery nothing helping.
Did you figured out what was the problem?? :rolleyes:
It's making me crazy !! o_O
 

ASK THE COMMUNITY

TRENDING THREADS