[SOLVED] BIOS settings resetting after reboot.

Jan 1, 2022
10
0
10
0
So every time I enter my BIOS I get this error " Clear Cmos Information - BIOS has been reset. Please re-config your BIOS setup items if needed." Most people told me the problem is from the CMOS battery but I got a brand new and nothing changed. Also saw on a forum that turning on the Power Load option was a fix for other people but unfortunately it wasn't for me. My PC is , CPU : ryzen 3700x , GPU : 2060s super , Mobo : Gigabyte aorus x570 ELITE . If anyone has any suggestions I'd like to try em out.
 

boju

Titan
Ambassador
Very rarely is it cmos battery especially being relatively new since those batteries last for years. Check that it's in properly though, in the battery holder and + symbol facing up.

Bios resetting itself is most likely memory or storage related. I would suspect memory first since there's a few discussions on this issue on GB 5xx boards over at Reddit and ram and xmp are the main points.

Check for bios updates and try single ram in 2nd slot from cpu. Try with and without xmp enabled.

What's your memory configuration, speed and slots used? And were you enabling xmp each time bios reset?
 

boju

Titan
Ambassador
Very rarely is it cmos battery especially being relatively new since those batteries last for years. Check that it's in properly though, in the battery holder and + symbol facing up.

Bios resetting itself is most likely memory or storage related. I would suspect memory first since there's a few discussions on this issue on GB 5xx boards over at Reddit and ram and xmp are the main points.

Check for bios updates and try single ram in 2nd slot from cpu. Try with and without xmp enabled.

What's your memory configuration, speed and slots used? And were you enabling xmp each time bios reset?
 
Jan 1, 2022
10
0
10
0
Very rarely is it cmos battery especially being relatively new since those batteries last for years. Check that it's in properly though, in the battery holder and + symbol facing up.

Bios resetting itself is most likely memory or storage related. I would suspect memory first since there's a few discussions on this issue on GB 5xx boards over at Reddit and ram and xmp are the main points.

Check for bios updates and try single ram in 2nd slot from cpu. Try with and without xmp enabled.

What's your memory configuration, speed and slots used? And were you enabling xmp each time bios reset?
Thanks for the quick response

Yes, I've checked and the CMOS battery and its placed correctly.
The RAM that im using is Team group t-force xcalibur rgb black ddr4 - 16gb (2x 8gb) 3600mhz cl 18-20-20-44 1.35
They are placed in slots 2 and 4 although i had them before in slot 1 and 3 and i still had the same problem.
Every time i enable xmp or do any change to the bios settings the moment i click save and exit and my pc boots the options are not saved and it works with the default bios settings.
 

boju

Titan
Ambassador
So memory isn't stable and motherboard resets. Try manually 2933/3200 with dram 1.35v for now if there's no xmp profile of lower speed.

If fast boot is on try disable it so motherboard has more time to train memory.

2&4 slots are the primaries, these slots are used first before the other two. For troubleshooting memory settings try only slot 2 populated.
 
Jan 1, 2022
10
0
10
0
So memory isn't stable and motherboard resets. Try manually 2933/3200 with dram 1.35v for now if there's no xmp profile of lower speed.

If fast boot is on try disable it so motherboard has more time to train memory.

2&4 slots are the primaries, these slots are used first before the other two. For troubleshooting memory settings try only slot 2 populated.
I just checked my BIOS version and its F3 which is the oldest version. Do you know if updating it to the newest one might fix it?
 
Jan 1, 2022
10
0
10
0
Possibly, there are memory compatibility updates so maybe.
Okey so we have progress. I Updated the bios to the newest version and a few things happened. I no longer get the error that the bios has been reset when i enter the bios and managed to enable XMP and i stayed after a restart. But other strange things happened. The speed of the RAM is still 2400 MHz even with XMP enabled. Also now when i exit the BIOS settings thru the save&exit button my pc shuts down and 1 second later boots up like usual. But 2 or 3 seconds since the pc started booting it shuts down for a second or 2 and it starts booting up again. This sequence of events happens like twice and then it boots up to windows.
 

boju

Titan
Ambassador
Did you disable fast boot? The reboots is part of memory training, once it's done that you can turn fast boot back on.

Ram are still in 2nd and 4th slot? Does your ram offer another xmp profile?
 
Jan 1, 2022
10
0
10
0
Possibly, there are memory compatibility updates so maybe.
Also another thing i checked thru the options for the memory in bios and these are options i currently have "XMP High Frequency Support,System Memory Multiplier, FCLK Frequency,UCLK Mode And Advanced Memory Settings in which i could check some statistics of how the ram works". Since it stays at 2.4k MHz i checked all the settings if i can manually put it at different Mhz's and on the "FCLK Frequency" option i could set from like "Auto" or in manually Mhz in the range from like a 100 to 4000 MHz. After a quick google i found out i have to put it to the same speed as the RAM which is 3.6k so i put it on 3600MHz but after saving and exit my memory stays at 2400 MHz (checking from the task manager)
 
Jan 1, 2022
10
0
10
0
Did you disable fast boot? The reboots is part of memory training, once it's done that you can turn fast boot back on.

Ram are still in 2nd and 4th slot? Does your ram offer another xmp profile?
Fast boot was set to disabled from the default settings. Yes They are still in 2nd and 4th slot i havent mooved them at all. And no the only 2 options for XMP are Disabled and Profile1
 

boju

Titan
Ambassador
Also another thing i checked thru the options for the memory in bios and these are options i currently have "XMP High Frequency Support,System Memory Multiplier, FCLK Frequency,UCLK Mode And Advanced Memory Settings in which i could check some statistics of how the ram works". Since it stays at 2.4k MHz i checked all the settings if i can manually put it at different Mhz's and on the "FCLK Frequency" option i could set from like "Auto" or in manually Mhz in the range from like a 100 to 4000 MHz. After a quick google i found out i have to put it to the same speed as the RAM which is 3.6k so i put it on 3600MHz but after saving and exit my memory stays at 2400 MHz (checking from the task manager)
Fast boot was set to disabled from the default settings. Yes They are still in 2nd and 4th slot i havent mooved them at all. And no the only 2 options for XMP are Disabled and Profile1
FCLK Frequency is infinity fabric speed, that will be 1800 for 3600 ram. Try that and also 1600 for 3200 speed and see how you go. Set dram voltage to 1.35v.

Can you upload pictures of memory and spd tabs please in Cpuz.
 
Jan 1, 2022
10
0
10
0
FCLK Frequency is infinity fabric speed, that will be 1800 for 3600 ram. Try that and also 1600 for 3200 speed and see how you go. Set dram voltage to 1.35v.

Can you upload pictures of memory and spd tabs please in Cpuz.
I set the FCLK Frequency to 1800 and the dram voltage to 1.35v and saved and exited. Checked again in task managed and the MHz were still 2400MHz. Went back into the bios settings and the FCLK Frequency was set back to default but the dram voltage is staying at 1.35v and im not getting the message that i used to get that its reset or something just the FCLK Frequency is going back to Auto. When i came back into the bios settings i set it to 1600 MHz now instead of the previous 1800 but it still says 2400MHz when i check in task manager.

Here are the pictures of the settings Pictures
 
Jan 1, 2022
10
0
10
0
Reset bios to optimised defaults and try xmp again.

After i switched the spots i went into the bios and set the FCLK Frequency to 1800 and "save&exit" and now it says 3600MHz on my task manager. Should i reset to optimised defaults and set it up again or just leave it as it is?
 

ASK THE COMMUNITY