[SOLVED] Bios update causing problems

Status
Not open for further replies.
Mar 11, 2022
17
2
25
0
So i bought motherboard it worked fine for few weeks but started getting start up problem so i updated bios but that just brought me more problems such as

Audio disortation
Game stuttering
Mouse stuttering
Stuck on shutdown / Reset screen
Audio driver uninstall stuck

Ive gone thru everything possible from windows reinstall to troubletshoots etc
now i have gotten 2 brand new motherboard thru warranty swap & holding 3rd one but havent tested it yet.
1st mag-x570-tomahawk-wifi
2nd rog strix x570-f
3rd rog strix x570-f
So basically the issue has been tested & tried by professionals i hope with mine & Their computers still having the same issue also the same parts works on my current motherboard b450 plus without any problems.
( I tried asking weither they tested it with windows 10 or 11 & fTPM disabled but they didnt have me asnwer)

So fair i noticed this recently but thats is yet to be tested
https://www.amd.com/en/support/kb/faq/pa-410
But i also did update bios with both motherboard but still had the issue & tried resetting default settings in bios
on X570-f The problems were there from the start

I don't really see anything else causing this than the recent bios update.
Somehow i feel there's some windows 11 kind of updates on bios that causing these problems other than the fTPM if thats even possible.
I only see 2 possible things to try which is disabling tFPM or trying windows 11 instead of 10 but I am too scared to even try the 3rd motherboard at this point if my case / Parts are damaging the motherboard somehow or something but yet the same cables/parts working fine on my b450 plus
If there's any other settings i should try to change in bios let me know
(ive tried asking help few timesbut hopefully i find some this last time i try)

I appericiate any help you can give even it sounds obivious <3

Specs
Windows 10
Tuf RTX 2060
AMD Ryzen 7 2700 ( Getting 9 5900x in mail monday)
Kingston 4x 8gb 3200MHz
Corsair RM750x 80 PLUS Gold ATX
b450 plus
M2 NVME SSD Blue 500gb
P400 Eclipse case
Razer keyboard & Mouse
Razer Headshet with Thx spatial audio
 
Last edited:
Mar 11, 2022
17
2
25
0
brand and model of the 750w psu?
how full is the ssd? test with another one?

Corsair RM750x 80 PLUS Gold ATX
that psu isn't even half year old & still have warranty & SSD has like 150gb left
( Dont have any other ssd to test but the people who did the warranty check covered that one )

Ive used the same CPU cable from psu on the x570 & B450 plus
 
Mar 11, 2022
17
2
25
0
I can now confirm that i managed to fix the problem i think by installion windows 11.
Day 2 without any issues on my new equipment.

Windows 10 reinstall still had the problems. So i suppose the new bios update have some windows 11 type of updates that fks up windows 10 somehow
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS