bios update error 0x00000406

omarhussain23

Prominent
Jan 4, 2018
7
0
510
0
Hello everyone, I have tried updating my BIOS on my Dell Inspiron 1545 several times but I am constantly getting an error code which I can't figure out what the problem is.

Error Code 0x00000406

An unexpected error occurred while running the flash application

Old BIOS version and date A14 07/12/2009

New BIOS version and date A14 07/07/2012

I am updating the BIOS because I am going to do a CPU upgrade to a quad core.

My Motherboard and Chipset are compatible but I must update the BIOS before installing the new quad core processor.

Dell has added new cpu support list in the new BIOS version.

I have checked by using this site which cpu's are compatible with my system
HWBOT.ORG


Then click on search this site on HWBOT.ORG

After clicking on search this site you type the motherboard number in.

My motherboard number is 0G848F
My chipset is GM45

Then you should be able to see on the website where it says VIEW other compatible processors.

Then you should be able to find the CPU somewhere through the list

CORE 2 QUAD Q9100

 

Colif

Titan
Moderator
Here is a copy of the BIOS that is update using a USB instead of windows -

This file format consists of a BIOS-executable file. To use it, download the file and copy it to a DOS-bootable USB flash drive, then boot the system to the USB flash drive and run the program.
http://www.dell.com/support/home/au/en/aubsd1/drivers/driversdetails?driverid=ndg06

I found this by searching for that error code - its not same Dell but it is similar: https://arstechnica.com/civis/viewtopic.php?t=1131658
 

omarhussain23

Prominent
Jan 4, 2018
7
0
510
0
Hi Colif,

Thanks for your answer

I will follow the instructions that you have given me.

First of all I download the BIOS file transfer it to a USB stick then I boot from the USB stick

Thanks for your help again.
 
if it still errors out contact dell. looks like they may have put up bios file for another product. as you look the bios rev is the same. that a red flag to me that the bios file is for another product that uses the same mb.
 

ASK THE COMMUNITY

TRENDING THREADS