• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Bios update fail

Apr 16, 2020
1
0
10
0
Heyo, so I recently got a used Sapphire r9 280x from ebay. I plugged it into my computer, where it worked but the bios was old, so I tried to update them. I went on to atiflash and found the most recent bios update and installed it. After the installation my computer no longer would display from the card, even though the fans were spinning. It looked to me that my computer completely didn't recognize that a gpu was even plugged in, and could only be launched in safe mode through the on board graphics. I know the computer isnt broken because I put my old gtx 760 back in and it is working completely fine again . But that r9 280x doesnt work at all anymore. Does anyone know whats wrong? I have looked everywhere, but nothing seems to work, is the card just broken?
 

vov4ik_il

Prominent
Mar 23, 2020
994
133
590
11
Looks like the memory timings on your new BIOS are off. You can probably flash it back to the one you had if you saved it.
In general, BIOS has the GPU Core model, memory timings and power options. You cannot just pick one with a similar name and use it.
Try to read the product ID from the sticker and find a good BIOS for it using this ID. I posted a guide on how to flash it with external tool.
 

ASK THE COMMUNITY