Question BIOS update for Aorus B450 Elite (revision 1) ?

Mar 16, 2023
so first of all hello everyone i'm new here .
i have 2 problems but as the title said first thing first-

1. i want to update my BIOS (just updating my BIOS, not upgrading anything)
currently i'm running Aorus B450 Elite non-wifi (revision 1)
BIOS Version F51 (date: 12/18/2019 & BIOS ID: 8A16BG08)

so what's my first step? i did my research and all of them was about updating BIOS when upgrading their CPU.
so i got lost there. because what i want to do is just update my BIOS, i'm assuming that you can't just intalled the latest one and call it a day, right?
i saw articles and threads about the step but as i said i got confused

i'm running:
Aorus B450 Elite non-wifi (revision 1)
Ryzen 5 2600
Corsair vengeance pro rgb 16GB

2. second problem...
it's related to "hardware reserved" on the RAM. Don't worry i did my homeworks and tried everything from regedit, memory management stuff-
reseating RAMs, checking cpu pins, tried different dimm slots. aaaaaaand, no result? my RAMs are fine i tested it on my friend's PC
also this happened 2 days ago since i posted this thread. my PC was fine and suddenly it run only 8gb of it while the OS detected i have 2 RAMs installed.
i noticed this problem when i was playing a game, the performance dropping and stuttered a bit. at first i was thinking it might be my GPU because i'm still running RX460.
but when i'm working on my dayjob in adobe photoshop it suddenly got choppy and the task manager showed 81% RAM usage. it never went that high before, at most, 42%
.... and the hardware reserved thing happened

english isn't my first language so i'm sorry if there are possibly confusing words
Mar 16, 2023
i will try to perform clean install to windows 11 as for now i'm running windows 10. i hope it will fix this issue :)

update: no result, still the same
should i update my bios? as last resort
Last edited: