Question BIOS update has made games unplayable

Aug 6, 2020
4
2
15
0
I was having an issue where on occasion my graphics card would stop sending a signal out during games. I read that this was somewhat of an issue and that AMD recommended updating the BIOS. So I found the newest version of the BIOS (F24) from Gigabyte's website and downloaded and unzipped it to a USB drive. I used Qflash to install it. I loaded up BF4 to test and it was working fine, until the next match and map had to load. Then the frames basically dropped to nothing and it looked a bit like the tunnel scene from 2001. Upon reloading the game again, it worked fine, but a map change completely tanked the game. Metro 2033 had a similar issue between levels, although I did get quite a bit of gameplay before this happened. Frame rates completely sag and input lag is off the charts. The worst off is my favorite game EUIV, which slowly but surely begin tank after 10-15 minutes.

I am assuming this a software issue as it happens when something loaded ingame. I have tried googling and messing with some of the BIOS settings, including loading optimized defaults into a profile and loading said profile. I have also Qflashed other versions of the BIOS, but to no avail. I am completely perplexed. Do I need to get a whole new motherboard? Any help would be appreciated.

PCPartPicker Part List: https://pcpartpicker.com/list/f6Nsdm

CPU Cooler: CRYORIG H7 49 CFM CPU Cooler
Motherboard: Gigabyte GA-H110M-A Micro ATX LGA1151 Motherboard

Memory: Kingston HyperX Fury Black 8 GB (1 x 8 GB) DDR4-2133 CL14 Memory x2

Storage: Seagate Barracuda 1 TB 3.5" 7200RPM Internal Hard Drive
Video Card: MSI Radeon RX 580 8 GB ARMOR OC Video Card

Case: Corsair 88R MicroATX Mid Tower Case

Power Supply: SeaSonic 520 W 80+ Bronze Certified Fully Modular ATX Power Supply

Wireless Network Adapter: Asus PCE-AC55BT B1 PCIe x1 802.11a/b/g/n/ac Wi-Fi Adapter

Edit: Interesting thing I've noticed. When EUIV slows down to a crawl (2-5 fps), if I tab out with task manager it "resets" and goes at normal speed. Absolutely perplexing.
 
Last edited:

kurdtnz

Upstanding
Feb 24, 2020
493
60
290
5
Did you buy a dual set of RAM or did you buy both sticks separately? Im not too sure about Intel but I know with AMD processers, they really dont like mixed RAM,(even when they are exactly the same make/model/speed etc.)
 
Aug 6, 2020
4
2
15
0
I bought each stick separately. Although it seems like it is moot point. My machine no longer posts. This is obviously some sort of hardware issue I don't quite grasp. The graphics card no longer even turns on its fans. I suspect it is an issue with the PCIe slot and the mobo as a whole. Very odd situation. I really appreciate you replying though. It's a pretty big boost to my morale that someone would even ask questions to help me.
 
Reactions: kurdtnz

ASK THE COMMUNITY

TRENDING THREADS