BIOS update problem

geoffry

Distinguished
Dec 30, 2006
61
0
18,630
I just flashed the BIOS on my main computer. The old BIOS was successfully backed up onto the floppy drive and then is had successfully updated the BIOS. Said "remove floppy and push f1".

I did, on the restart, my screens are blank...all 3 show nothing, the light just blinks...

The computer starts up fine but I have no idea what its doing because I can't see.

Any ideas?
 
Ahhh, not a good sign, at all.
Try to clear your BIOS with the jumper on the board.
If resetting it won't work, unfortunately, you are stuck till you get a new BIOS chip from your motherboard manufacturer.

Botched BIOS flash = dead motherboard.
It happens, any little glitch at all and that's what you end up with.
 

geoffry

Distinguished
Dec 30, 2006
61
0
18,630
Thats just perfect...

You would not believe how mad I am at myself right now.

I bought a socket 939 CPU to prolong the life of the comp and now the mobo is fried, CPU is out of the box and I might as well have got a C2D system fresh...
 

aBg_rOnGak

Distinguished
Feb 23, 2006
481
0
18,790
So, how is it now? Working?You might want to try clearing the bios as suggested, then boot into bios with minimal hardware (1 piece of ram, no hd/optical drive etc)
 
The new/replacement chip will have the latest BIOS for your board flashed to it already.
Your PC has to have a BIOS chip with the correct, and more importantly- a working version of the software stored on it to boot.
A lot of people automatically recommend that you should flash your BIOS to the latest version, if a newer one is available.
But, unless the new version has improvements to fix a specific problem you are having, updating your BIOS has no benefit.
 

geoffry

Distinguished
Dec 30, 2006
61
0
18,630
You can say that again....I should have tried the dual core CPU first and made sure a flash was needed.

Doh, live and learn I guess...
 

geoffry

Distinguished
Dec 30, 2006
61
0
18,630
OK, I figured out the problem but ran into another....

I have installed the new CPU and PSU but cant get into windows.

I have reflashed the BIOS about 10 times now and it never updates, yet it says it was successful.

I can't boot windows, I can't use the setup CD to reinstall windows, I'm totally stumped. (when trying to reinstall windows it loads the setup files then restarts)
 

geoffry

Distinguished
Dec 30, 2006
61
0
18,630
Update....I got it working:) New CPU, ram and PSU all working like a charm now...

I figured if the CMOS chip was fried I might as well fiddle with every jumper I could get my hands on...eventually a combo worked.