Question BIOS update stuck

Feb 18, 2021
3
0
10
0
Hi there,

I hope you guys can help me cause i've tried everything i know so far.

The problem is when i boot the computer i get the message:
"BIOS is updating. Do not shut down or reset the system to prevent system bootup failure".

I can't do anything to get past this screen and im not able to get it to any type of factory reset or anything. So that's why im here to pick your genius brains.

This are the specs:
  • ASUS Rampage V Extreme / U3.1
  • Intel Core i7-5960X 3.0 GHZ
  • Crucial Ballistix 32GB DDR4-2400
  • Asus GTX 980 Ti 6GB
What i tried so far:

  • Tried the reset CHMOS button multiple times
  • Removed the battery and disconnected power for more then a minute
  • Removed all the RAM, SSD + HDD
  • Downloaded latest BIOS, put it on a clean USB (cleaned with SD formatter) renamed to R5E.CAP and tried to install (but the ROF connect button will never light up).
  • Did the same with an older version of the BIOS
  • Tried to start with support disk, nothing happens
  • Tried switch BIOS button
  • Tried Save Boot button
  • Tried reset button
And now im out of ideas. You guys have anyway for me to go on and try something else?
 

Zerk2012

Titan
Ambassador
Hi there,

I hope you guys can help me cause i've tried everything i know so far.

The problem is when i boot the computer i get the message:
"BIOS is updating. Do not shut down or reset the system to prevent system bootup failure".

I can't do anything to get past this screen and im not able to get it to any type of factory reset or anything. So that's why im here to pick your genius brains.

This are the specs:
  • ASUS Rampage V Extreme / U3.1
  • Intel Core i7-5960X 3.0 GHZ
  • Crucial Ballistix 32GB DDR4-2400
  • Asus GTX 980 Ti 6GB
What i tried so far:

  • Tried the reset CHMOS button multiple times
  • Removed the battery and disconnected power for more then a minute
  • Removed all the RAM, SSD + HDD
  • Downloaded latest BIOS, put it on a clean USB (cleaned with SD formatter) renamed to R5E.CAP and tried to install (but the ROF connect button will never light up).
  • Did the same with an older version of the BIOS
  • Tried to start with support disk, nothing happens
  • Tried switch BIOS button
  • Tried Save Boot button
  • Tried reset button
And now im out of ideas. You guys have anyway for me to go on and try something else?
Did you put the USB drive in the right USB slot? Should be the bottom one where the old style mouse connector is on the back.

Old style plug.
USB below that plug.
USB below that USB * that one.
 
Feb 18, 2021
3
0
10
0
Yea, though the documentation states that you need to presse the ROG button until the BIOS light blinks. I'm not getting any lights blinking anywhere.
 

ASK THE COMMUNITY

TRENDING THREADS