Question Bios update x470, no post either 2 different gen cpu

ledesmacody

Commendable
Aug 24, 2017
5
0
1,510
0
Hello, I started a new build on ryzen with an x470 board. I borrowed a friend's 2200g to install the necessity and then downloaded the newest bios on to mobo. It went through the 100% updating section then booted straight into windows with no issue. I thought everything was set so I removed the 2200g and placed the 3700x in and the gpu fan ramped up and never went down. No post or any display, Ive tried the ram in different configs. I tried putting back the 2200g and that also won't boot with the same issue

I've tried:
  • one stick on different slots
  • using the integrated gpu on the 2200g
  • resetting bios with the jumper
  • leaving each cpu on for a bit longer
  • use the bios recovery feature on the asus board with both a new bios on a USB stick and the old default on, and also the cd
  • I've tried using the speaker module to get error codes, even when I only had the cpu on it and no ram there's still no beeps to indicate what's the problem
Cpu: 3700x and 2200g
Ram: Trident Z Neo 3600c16
Gpu: Rtx 2080 founders edition

Any help would be appreciated, I've been stuck on it for hours now and would love to just play minecraft

Thanks
 
If you updated the BIOS to the one that supports Ryzen 3000 series.
Try this:
Power off the computer and disconnect the power cord from PSU.
Press the power button for 20 seconds.
Remove the Ryzen CPU , remove the CMOS battery from motherboard.
Wait a couple of minutes then reinstall the CMOS battery.
Install the new Ryzen CPU, plug the power cord and press the power button.
The computer might turn on and off several times (3-7 times) and that could take up to 6 minutes...leave it alone.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS