[SOLVED] BIOS updated but R5 5600x still wont post

benwalker12004

Commendable
Aug 11, 2018
4
0
1,510
Today I built my new pc, specs are:
Ryzen 5 5600x
Gigabyte B550 Aorus Elite V2 Motherboard
Corsair Vengeance RGB Pro 16GB (2x8GB) 3200MHz CL16 DDR4
Corsair iCUE 4000X RGB Tempered Glass Mid Tower Case Black
Samsung 860 EVO M.2 SATA SSD 500GB
Corsair RM750 Gold 750W Power Supply

I knew that the motherboard needed a bios update, I tried to flash update but it wouldn't work for some reason and I know that I did everything right, then I thought, okay, well I should put my old Ryzen 3 2200g in there so I can get to bios, so I did that. When I reached bios I updated the bios to F10 from the flash drive with the same files that I tried to Q-flash. Now that I updated the BIOS to F10 it should be compatible with 5000 series processors right? Well I put the new processer in and it still wont post to BIOS even though it is on F10 update. I am stumped on what to do now. Ask any questions I am keen to respond,

Thank you <3
 
Solution
For the new CPU to work, you must install a GPU. Even though the motherboard has video ports, they don't work with the 5600x.

Only Ryzen models ending in "G" have on-board video.

TRENDING THREADS