Question BIOS will not Post after flashing, no display

Jul 22, 2022
1
0
10
0
I have an MSI Pro Z690-A DDR4 motherboard that initially booted up just fine, but I noticed it had an outdated BIOS and I (regrettably now) flashed the BIOS with the updated version from the MSI website. Now my PC will turn on (lights up, fans on) but I have no display. I’ve tried reflashing using the flash button on the I/O connectors with a usb drive, went through the steps and it did successfully reflash based of the manual. I’ve tried resetting CMOS, both by shorting the JBAT and taking out the battery (I have no reset button) I’ve unplugged everything, replugged it, taken out all but one RAM stick, plugged the hdmi into both the motherboard and GPU whilst conducting the tests. I am honestly completely lost on what I need to do. Also the debug LEDS on my motherboard are fine and not lit up. My monitor works just fine.

Just to clarify, this is a new build and I was initially able to boot into windows, it would not connect to the internet and tried updating the drivers to no avail. That’s when I tried updating the BIOS initially using the M-Flash from the bios menu, then used the flash BIOS button on the back of the I/O connectors to reflash when it wouldn’t boot.

Specs:

Motherboard: MSI Pro Z690-A DDR4
GPU: EVGA RTX 3080 12Gb
CPU: Intel I7-12700kf
Ram: G.Skills Ripjaws V series 32GB DDR4 (2x 16gb) 3600
Storage: Samsung 970 EVO Plus 2tb SSD M.2 NVMe; Samsung 970 EVO Plus 1tb SSD M.2 NVMe
OS: Windows 10 home
PSU: EVGA SuperNOVA 850 G+ 850w Gold
 
Last edited:

ASK THE COMMUNITY