bios will only see 1 drive

steelaw

Distinguished
Nov 9, 2007
10
0
18,510
0
ok i just got a asus pk5e mobo it has 6 sata ports and 1 ide port it will only read 1 hard drive at a time meaning when i have the both connected it will read only 1 .when i enable master on the ide hard drive it will read that one but not the sata.when i switch the ide to the slave 2nd or cs it will only read the sata now heres where im really confused when i have the dvd burner on the ide ribbon it reads that no problem and yes i have tried changing the boot order please some one instructed me on how to fix this problem.
 

MrCommunistGen

Distinguished
Jun 7, 2005
1,042
0
19,310
8
Check the RAID settings. Make sure your BIOS are up to date. Try different cables. I can't really think of much else and none of those really sound like they'd be the problem but shouldn't hurt.

-mcg
 

MrCommunistGen

Distinguished
Jun 7, 2005
1,042
0
19,310
8
I meant check the RAID settings. Even if you don't have a RAID, if the motherboard is set to use RAID it can mess things up. I added a SATA drive to my computer to back stuff up before a wipe and RAID was enabled for all of my drives and that made it so that my 2x160GB drives no longer functioned as a RAID and the system wouldn't recognize the new drive either... although I think they were all detected in BIOS fine. I'm really at a loss. Which SATA port you use shouldn't matter but feel free to change it just to cover all the bases.

-mcg
 

MrCommunistGen

Distinguished
Jun 7, 2005
1,042
0
19,310
8
Have you tried changing those settings? I don't have those options so I don't really know what they mean, but having the SATA set to IDE mode sounds like it might make it so the SATA drives can interact with IDE drives... which is what seems to be happening.

-mcg
 

Zorg

Splendid
May 31, 2004
6,732
0
25,790
1
I don't know about that board, but setting SATA to IDE mode means it's not AHCI, which is fine. You just don't get hot swap, NCQ, or technically RAID even though RAID has it's own setting. Set the drive as IDE and Compatible, and plug it into SATA1. Why would you plug it into SATA6 anyway. No guaranties but it's worth a shot.
 

Similar threads


ASK THE COMMUNITY