Question BIOS won't boot from SSD (SAMSUNG SSD PM871b), Alienware 17 R4

Mar 27, 2020
1
0
10
0
Please do give it a read if you or your friends own a AW laptop. and please to forward it to your expert friends who might be able to help.
This is a long post, inshort my BIOS(latest update from feb 2020) won't boot from my SAMSUNG SSD PM871b even though i have tried multiple ways to install the OS.
edit: i just found this, here its says samsung SSD is no more compatible with AW to boot OS from. but it can still be used for storage. is this true
will it help fix the problem if i rollback my BIOS update? if so, whats the best way to do it?

and the complete post here
i have been struggling to install windows 10 on my SSD
for more than a month now. i did my research and turns out a lot of people have been struggling with the same issue and dell hasn't paid any attention to it in so many years.
either installing windows on SSD becomes an issue, or i succeed installing it on the SSD but the BIOS fails to boot the OS from it.
but at the same time the HDD installs and boots windows 10 with no issues whatsoever, except for the slow boot time which is why i wanted to switch to the SSD in the first place.
note(IMPORTANT): in BIOS main screen the SSD is listed under "HDD" even though there is a category called "M.2 PCIe SSD" where it is supposed to be listed under. this sounds like a serious bug to me.
following is a list of the things i tried and failed. i mentioned almost everything i landed upon in a month long research for the sake of documentation so it might help others. i find this important because i found hundreds of users with the same problem and this could be of great help for them (estimated based on number of posts, likes and comments and i believe there could be thousands who just look up without leaving any traces). please feel free to add any other method you have tried if you have faced the same issue, i will add it to this post. please do mention if you have succeeded or failed while doing so.
  1. switching between mbr, gpt on my SSD and rebuilding it using cmd
  2. all combinations of RAID, AHCI, secureboot, UEFI, legacy
  3. trying out diskpart in cmd to clean my SSD before installation
  4. physically removed my HDD during the installation process to force the BIOS preference to boot from my SSD. tried this along with all kind of other approaches that i have mentioned here.
  5. tried different sources of windows 10 ((1). windows original installation disk's iso file which my university bought from microsoft, it had every edition of windows, starting from home to workstation,1909 build, i tried the workstation(later i found out it isnt such a great idea for gamers, i need opinions, is it true?), (2). windows official media creation tool(home edition), (3). windows iso downloader by heidoc.net(Enterprise))
  6. i successfully installed on my SSD, but the BIOS would fail to boot from it. This happened with windows media creation tool as well as the iso from my university(used rufus).
  7. follow up of 6: through windows 10 from my HDD --> changed "default OS" under boot tab in "system configuration". however, when i set the SSD to be "default OS", the BIOS tries to boot from it and fails with an error screen. when it fails, i have an option to choose another OS from a different drive and i can still enter the OS on my HDD.
  8. follow up of 6: i tried boot preferences under BIOS by playing with UEFI and Legacy, the BIOS tries to boot from SSD and fails. but when HDD is set as priority, boots up with no issues once again.
  9. during the installation of windows using the iso from heidoc.net, when i try to choose the disk where i want to install the OS at, there's a prompt at the bottom saying "windows cannot be installed on this disk" and will not allow me to choose my SSD. so i tried the fix mentioned in link, using " iaStorAC.ing " intel RST driver to help the installation use the SSD. Did not work. it didn't allow me to boot from my HDD as well. must be an issue with the iso file from heidoc.net. Also i read somewhere, that the BIOS embedded product key prevents me from installing a different edition of windows 10 other than the one it came with. i tried enterprise edition in this case. but it doesnt seem to be a problem since im currently running workstation from my HDD.
  10. I/O error 0x80300002 when trying to install with different RAID, AHCI options in bios, like here
  11. here, it was mentioned alienware supportassist OS recovery helps reset the PC to factory settings and successfully installs a new copy of OS in SSD. should solve the problem right..
    Did not work. But something interesting happened. After failing multiple times, i tried "repair system" which was a part of the supportassist, and it looked out for issues in my PC and it said "Boot file: corrupt". i don't know what this means, and it had no option to fix it either. This had me thinking, what if the BIOS in itself is corrupt somehow when i installed the latest update of system BIOS (v1.9.0) that just came out in feb 2020. what do you guys think about rolling back BIOS? if its even possible.
Anyways, here's a list of things i havent tried due to various reasons
  1. A friend suggested me to change the BIOS in itself, to the BIOS of MSI or someother PC. But that seemed too risky as i might lose access to my hardware forever if i screw it up. also i read some PCs have multiple BIOS chips and they have a fail proof mechanism. i might give it a go when i do enough research and im confident enough or i will wait until someone convinces me.
  2. cloning my HDD to SSD. I tried macrium reflect but it failed because HDD was in 512 sector and the SSD was in 4k. also there was a workaround of making iso files and then burning it on my SSD. but i lost hope at this point ever since the BIOS error showed up during the supportassis analysis saying "Boot file: corrupt"
  3. there was a couple of instructions here. i didnt try them because of the comments.
  4. AlienRespawn as it supports till windows 8(im not very sure though)
sorry for the long post. i realised such a prominent issue hasnt been addressed and most forums seem to suggest typical responses such as formatting SSD and using official media creation tool etc. but this issue isn't like most other common errors that we find among OS boot issues, this problem is very specific among alienware PCs, i know this from how hundreds of people have described how their laptop behaves and they behave just like mine. without SSD, the laptop is underperforming and for an expensive machine its a major issue. dell seems to have no response to it though this issue has been pertaining for years now. i am really frustrated with dell right now. this is not what i paid for. please forward this post to your friends and upvote so it gets more viewers that in turn helps me get more support from the community. thanks in advance.
PS: my warranty expired and i can't talk to dell support
relevant specs of my AW 17 R4
BIOS version 1.9.0 (released 1/2/2020)
SSD SAMSUNG SSD PM871b M.2 2280 128GB
HDD HGST Travelstar 7K1000 HTS721010A9E630 (0J22423) 1TB

PS: this is a linkto my original post, it has a list of links where i have posted this, so you can keep check out everyother discussion if you got the same problem
 

ASK THE COMMUNITY

TRENDING THREADS