Bios won't let me change the boot order

flightoftherat

Prominent
Dec 9, 2017
55
0
640
1
Hello dear community

I cloned 250 gb from my Toshiba 4T HDD to my new Samsung 500 gb M.2 NMVe SSD. When the process was completed I shut down the PC, disconnected the SATA6 of the HDD and back again. I checked first the Bios and it showed this:



Why does it show 3 Samsung SSD btw? It did the same with the Toshiba.

Ok, so it booted very quick and everything worked flawless, the system boots and is working nice and fast from the SSD. The difference is remarkable!

Now, shut down again, connected the HDD (I want to restore it for storage), visited the Bios first and surprise, the same 3 Samsung items of the previous picture, were now listed as Toshiba HDD. The SSD was kicked to the bottom of the list as just 1 single item, so I clicked it and place it first. Saved and exited (The Bios told me that there wasn't changes to save) and Windows booted but from the HDD. Worked fine anyway, but I was expecting a boot from the SSD. I looked for the SSD and Windows didn't show it (Maybe because both were listed as C: ? ). Shut down and disconnect the HDD again, system boot from the SSD as before and everything worked fine.

I could leave the HDD disconnected and live with it but I need it as storage. If I manage to boot from the SSD, there's a chance that Windows won't show the HDD and I won't be able to restore it.

Please help, it seems like the Bios won't let me change the boot order.

Sorry if I sound too noob, but this is the first PC I build and I've faced all kind of problems so far. I've learnt a lot!


Edit: My mobo is an Asus rog strix Z370-G wifi/ac and the SSD is connected to the M.2 port.
 

KittyFish62

Respectable
Dec 13, 2016
567
0
2,160
73
The boot priority doesn't really matter. All that does is if it can't boot from one drive it'll go to the next drive. What you want to do is go to that place at the bottom right at the screen, "Boot Menu(F8)". There you can change what drive to boot from.
 

flightoftherat

Prominent
Dec 9, 2017
55
0
640
1
Thanks Kitty, that should do it. I'll try when I get home.

Do you know why the bios shows 3 items of the SSD instead of just one? Also, why didn't Windows show the SSD when it booted from the HDD, even though the SSD was connected and recognized by the bios?
 

flightoftherat

Prominent
Dec 9, 2017
55
0
640
1
I just can't make it work. When entering into the boot menu, these are the options available (when both the SSD and HDD are connected)



It won't allow me to make any change, if I click the SSD, the screen goes black and nothing else happens, it goes back to the Bios after 5 seconds. In the priority menu, the SSD is first.

Maybe the Windows Boot Manager has something to do with this issue, when the HDD and the SSD are together, the Bios assigns the "Windows Boot Manager" title to the HDD, even though the SSD is first in the priority, so it will always boot from the HDD by default. To the contrary, when the SSD is alone, the Windows Boot Manager title is assigned to the SSD as shown in the first picture.

I forgot to mention that my SSD is connected to the M.2 Port

It's getting on my nerves this thing that I can't have both drives connected. Like the SSD is a clone of the HDD, both have the same Win 10 OS and both are C: ... I don't feel like taking the HDD out and get it wiped elsewhere.

Please any advice?

Thank you!

 
Aug 2, 2019
8
0
10
0
Might be a bit late but I think the problem is that the other drive is not an SSD. To change the boot order
  • click f7 to go to advanced mode
  • go right on the tabs to the boot menu
  • click on Hard Drive BBS Priorities
  • From there you can define boot order of all drives
 

ASK THE COMMUNITY

TRENDING THREADS