Question Bios won't start with Xmp/Expo

Feb 20, 2022
Hi, I purchased Kingston FURY Beast DDR5 RGB 32GB 5600MT/s (KF556C36BBEAK2-32), but when I try to activate both Xmp and Expo, on the first attempt the pc starts, but from the subsequent starts the bios doesn't start anymore and then I have to reset the bios settings.
I tried putting Xmp from 5200 the pc starts, but then I have a crash with blue screen
I tried manually setting 5600 with 1.4v, but nothing changed. Does that mean they are incompatible so I should either change them or wait for a bios update?
thank you.

My configuration is:

Ryzen 5 7600X
Gigabyte X670 Gaming x ax
Arctic liquid freezer II 280 A-rgb


At the time of writing, it seems you have the the latest BIOS listed on Gigabyte's support site;
and your sticks of ram are populating slots A2+B2 as suggested in the motherboard manual.

Can you input the frequency and timings that are advertised on the ram kit into BIOS manually? Try and clear the CMOS, removing the battery after disconnecting from the wall and display and then try again in BIOS. Check and see if any pins on your motherboard are bent or broken. While you reseat the cooler onto the processor, once tightened all the way, perform a 90 deg anti-clockwise turn for each screw(to relieve some stress on the mount), then enabling the ram profile(s) in BIOS helps.

Does that mean they are incompatible so I should either change them or wait for a bios update?
IMHO, if you can, return the ram kit and pick another one from the memory QVL listed on the motherboard's support site, even though oddly enough the ram kit you currently have is listed on the QVL. Being an early adopter means that you inadvertently end up being the guinea pig. You could wait for a BIOS update then again it might not be anytime soon that a BIOS version might come to release.

To point out, the BIOS version you're on is actually an alpha(if you follow through Greek alphabets) so a full version/proper release would be one without any alphabets at the end of the number.