Question BIOS won't start

Jun 6, 2022
4
0
10
0
I have a gigabyte aorus x570 elite and I've been having some problems with it recently, for starters the bios resets almost every time i restart my computer, thus resetting my settings (secure boot, XMP etc.) and recently when I have tried to go into BIOS, it has said the following: Clear CMOS something, and then it says BIOS has been reset and something more. So I press the button saying "ok" and then the monitor just turns grey and I can wait for dozens of minutes and it still won't turn on. My PC also doesn't always start, especially not when my monitors are turned on, and if it takes more than 2 tries the date changes to like year 2302 or something like that. Please, can anybody help?
 
I have a gigabyte aorus x570 elite and I've been having some problems with it recently, for starters the bios resets almost every time i restart my computer, thus resetting my settings (secure boot, XMP etc.) and recently when I have tried to go into BIOS, it has said the following: Clear CMOS something, and then it says BIOS has been reset and something more. So I press the button saying "ok" and then the monitor just turns grey and I can wait for dozens of minutes and it still won't turn on. My PC also doesn't always start, especially not when my monitors are turned on, and if it takes more than 2 tries the date changes to like year 2302 or something like that. Please, can anybody help?
Has it ever worked?

Have you cleared CMOS manually: with removing the battery and shorting the pins for a few minutes?

If you have and it's still doing this the battery could be bad, so replace that. A bad battery means CMOS won't reliably hold settings and has to re-train memory at every startup, which can take time.
 

ASK THE COMMUNITY

TRENDING THREADS