Question Bizarre drive swap now required to get past POST

Feb 8, 2020
6
0
10
0
Apologies for the lengthy post, but I cannot find info on this issue anywhere.

A friend’s PB imedia S2885 started running very slow and after checking Win logs (constant bad block error) and a check disk for bad cluster conformation I decided to replace the drive with another 1TB WD Blue... like for like.

I cloned the drive with True Image and it all seemed fine until the first reboot... system hang at POST. It acknowledged a Del keypress and changed to “entering setup” but didn’t actually go any further. I just presumed it was an issue with the clone so performed a clean install and was shocked when it did exactly the same thing after a reboot during setup.

I then tried 2 different Toshiba hard drives (working in other systems) in case it was a weird firmware issue... same problem. I then swapped back to the original drive and also now have the same problem with it too!

Tried with and without Secure Boot and CSM disabled/enabled. Also swapped out the RAM. Cleared the CMOS and replaced the battery, but none of the setting were changed prior to the issue. It’s on a P11-B1 Acer BIOS which appears to be later revision than they currently offer for download. I will try another PSU, but could this be an issue with the mobo due to damage during the drive swap?

TLDR: First boot after a drive swap (to any single drive) containing a Win 10 install works then a shutdown/boot or restart hangs at “press del to enter setup” PB logo screen. Switching to another drive, booting, then back again lets the drive boot... once.
 

gmagdna

Prominent
Jul 16, 2018
127
15
595
1
You can try swapping the SATA cable for a known good once. A faulty one won't cause actual bad blocks or sectors on a HDD, but the data errors they cause can make chkdsk think the drive had faults.

The other other, less desirable option, is that the SATA controller is faulty.


Are you able to try the drive with the clean install in another machine to see if it boots correctly? If it will then you know it's a hardware issue on the other machine. If it won't boot, that's not decisive on hardware or software because it could still be a cable or controller issue.
 
Reactions: Alan Philp
Feb 8, 2020
6
0
10
0
Thanks for the reply (y)

Sorry, I should have mentioned I tried a new SATA cable... forgetting what I’ve done now. Another bizarre aspect is that the system halts in exactly the same way with a drive connected using a USB to SATA adapter. Again, the first boot is OK then it halts after a reboot... with nothing connected to the on-board SATA controller!

The drive(s) do work on other systems and I think I have narrowed down the issue to a partially corrupt UEFI BIOS. Fortunately the P11-B1 revision has a CSM option so I performed a clean install on a system with a legacy BIOS and swapped it over... all working fine. He can live without UEFI.

The iMedia S2885 is supposedly identical to the Acer aspire XC-603 which has a later BIOS revision P11-B4, but it fails to verify the existing BIOS and fails to update. The only BIOS officially available for the iMedia S2885 is P11-A3 which doesn’t have the Launch CSM option so I don’t want to risk losing the legacy install workaround. The system shipped with Win 8 and P11-B1 BIOS so no idea why it’s not available anywhere for download now.

I would suspect some sort of malicious injection if this hadn’t started offline during a drive swap. It was a brand new drive and True Image boot CD I have been using for years.

EDIT: I see the post was moved, but it does appear to be a mobo/BIOS issue.
 

ASK THE COMMUNITY

TRENDING THREADS