[SOLVED] Black Screen Crash When Launching Game, Fans At 100%

Status
Not open for further replies.
Mar 11, 2020
3
0
10
0
Hello, I bought a Dell G5 gaming computer about 2-3 weeks ago and have been using it with no issues until last night. I was playing a game (Sekiro) when suddenly the monitor went into black screen (i.e. power-saving mode) and the fans turned on 100%. The only thing I could do at this point was to restart the computer manually with the power button.

Now after restarting the desktop, the same crash happens every time the game launches (I can get past the main menu but it crashes as soon as the actual game loads, i.e. when the graphics become GPU-intensive). I've tried with other games that worked fine until last night and the exact same thing happens. The same thing also happens when I do a GPU stress test with the Dell SupportAssist app.

Details about PC:
  • Dell G5 Gaming Computer
  • 9th Gen Intel® Core™ i7 9700
  • NVIDIA® GeForce® GTX 2060
So far, my attempts to troubleshoot this have been to:
  • Make sure all drivers are updated
  • Download latest GTX 2060 display drivers
  • Make sure GPU is properly connected to the PSU
  • Restarting computer many times
I also called Dell support today since I am under warranty. It took the support agent 2 hours to do the basic troubleshooting steps I had already done, and in the end, her only solution was to offer that I send the computer in so that they can replace the GPU.

I find it very odd that it was working fine for over 2 weeks and suddenly stopped working last night. I would much rather not have to send it back in and wait 2-3 weeks before being able to use my computer again, so if anyone can provide advice on a potential fix, it would be MUCH appreciated! I have searched this forum and found multiple posts of people experiencing similar issues, but no one has posted a clear fix yet afaik.

Thanks so much for the help!
 
Last edited:
Dell has a reputation of providing PSU's that cut it really close to what the wattage of the system is. They did it for my previous 2 prebuilts. Try and find out what the wattage, make and model of the PSU is. Seems like a PSU issue to me.
 
Status
Not open for further replies.

ASK THE COMMUNITY