Question Black screen freeze with glitched audio

Apr 17, 2021
3
0
10
0
Hi I am currently playing Outriders and I keep getting Black screen crashes/freezes. I have tried all the graphics on low, checked all the temps and they're fine.
This has also happened with some other games before:

Happened with: Borderlands 3 and Destiny 2 with either low/max settings.
Never happened with: GTA V, Division 2, Warzone and a few other big titles all on max settings.

My specs are:
GPU: RX5700XT
CPU: RYZEN 1600 (Had the 3700x but snapped a pin so waiting on new stock) still happened with the 3700x though.
RAM:32GB DDR4
PSU: CORSAIR 600W BRONZE
MOBO: B550 Tomahawk

I have no idea why this is happening but really the only thing I have left to change in the PC is the GPU, as I did replace, CPU, MOBO, RAM and it still happens.
I have done stress tests on the GPU and it has been fine, same with cpu. I don't know what to do next, any recommendations, thanks?
 

Vic 40

Titan
Ambassador
Which psu exactly? =maker+model+wattage. Only Corsair 600watt abit recent in my mind is the CX(M) series which are old by now and not the best especially with such a gpu you use so that might give problems.

The ram is 2x16gb or 4x8gb? With the 1600 would that (4x8gb) give problems.

There is also a very recent bios, although Beta bios might it be good to update.
 
Apr 17, 2021
3
0
10
0
Which psu exactly? =maker+model+wattage. Only Corsair 600watt abit recent in my mind is the CX(M) series which are old by now and not the best especially with such a gpu you use so that might give problems.

The ram is 2x16gb or 4x8gb? With the 1600 would that (4x8gb) give problems.

There is also a very recent bios, although Beta bios might it be good to update.
PSU: Corsair CX600 Bronze. 2X16GB 3600 C18 Corsair but at 2666 because of the CPU. And I do have the latest Bios update. Might have to get a new PSU and try that, as it's really the only thing other than the GPU i've not replaced.
 

Vic 40

Titan
Ambassador
PSU: Corsair CX600 Bronze
Yeah though it would be that one, old and not something you want to run a RX 5700 XT on. Would start there.

MY 1600 did 3000mhz, so could try that. Otherwise with 2666mhz try lower timings. First time i had that AMD system with older bios ands the1600 would it not run past 2666mhz, but it would do it on 14-14-14-28 timings if i remember well.
 

ASK THE COMMUNITY