Question Black screen on boot up after upgrading graphics card

May 26, 2019
3
0
10
0
Hi, I am new to this and have limited knowledge.

I upgraded my graphics card from a GTX 770 to an ASUS STRIX GTX 980 ti. I have connected the 2 6+2 connectors as it has 2 8 pin sockets and gotten 2 white LEDs stating they are connected correctly.

When I boot up the system all fans, LEDs kick in, I can hear the hard drive loading but nothing else happens. The graphics card glows red along the side and this flashes (I am unsure if that is normal or if it should just be a solid light)

The system runs for around 2 minutes when I finally get a single short beep which it use to do straight away on start up (after research I believe this is the posting beep) the monitor will LED will go green and it will say no signal on the screen and then just go black. I get no boot screen or anything on the monitor at all. The motherboard is a Gigabyte GA-X79-UP4. I have tried removing the battery, resetting the CMOS and still get nothing and the same beep after around 2 minutes. I have removed the new card a few times to re seat it and also made sure all wires on the motherboard are seated correctly but still nothing. I have tried removing the RAM and re seating that and still nothing. I have tried to plug the monitor into different ports to see if that helped but still got a black screen.

My power unit is 600w so I don’t believe that to be the problem.

Any suggestions would be greatly appreciated.

Thanks
 
May 26, 2019
3
0
10
0
Thanks for your response.

The power unit is a cooler master RS-600-ACAB-D3, I have 2x 8gb corsair RAM, a cool master liquid cooler (I am unsure of model) and an i7 processor.
 
May 26, 2019
3
0
10
0
Thanks, I have just tried that by running the DUU driver installer. I have also updated the bios and still have a black screen when I put the 980 in. I have now also updated the PSU to a Corsair GS800.
 

ASK THE COMMUNITY

TRENDING THREADS