Question Black screen when gaming, still hear audio, need restart manually

Nov 2, 2022
3
0
10
0
Hi everybody !

I have different issues with my setup since 3 weeks.

Setup specifications :

Windows 11
ZOTAC 3090
12700 KF Intel
32 gb RAM
Z690 Gaming X DDR4 Motherboard
PSU is RM850x

It started with OW 2.. I was not able to finish a game because my screen turned to black but i still hear the audio from Discord. I can hear people speaking on discord but they dont hear me. (I was on Windows 10 when this happened)

I thought i solved this problem by doing OCCT test and high temperature crash. I changed the thermal paste and i never had this problem since done like 15 days ago.

I tried today to run Ark Survival Evolved, and it came back... Black screen, still hear audio, need to manually restart the computer. The game's presets were in "Epic" when it happened.

If you experienced the same issue, i would really appreciate your help.
Thank you
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

ZOTAC 3090
PSU is RM850x

you're advised to have a PSU that's 1.2KW or higher due to transient load spikes. An aged PSU won't output the advertised wattage due to wear and tear(and age). Try and borrow a higher wattage PSU and see if the issue persists.
 
Nov 2, 2022
3
0
10
0
Welcome to the forums, newcomer!

ZOTAC 3090
PSU is RM850x

you're advised to have a PSU that's 1.2KW or higher due to transient load spikes. An aged PSU won't output the advertised wattage due to wear and tear(and age). Try and borrow a higher wattage PSU and see if the issue persists.

Thank you for your Answer Lutfij !

The thing is i bought my PSU with all my setup 1 year ago and it was build by a custom gaming shop. The only thing i have changed is switch from a 3900x AMD CPU to 12700 KF Intel, added some RAM and changed the motherboard. My power supply is an old model ? 850w is not enough for my setup ?

Thank you for your help
 
Nov 2, 2022
3
0
10
0
Welcome to the forums, newcomer!

ZOTAC 3090
PSU is RM850x

you're advised to have a PSU that's 1.2KW or higher due to transient load spikes. An aged PSU won't output the advertised wattage due to wear and tear(and age). Try and borrow a higher wattage PSU and see if the issue persists.

I have just checked my setup and in fact, it's TX850M and not an RM850x... so it's maybe not why i have this "bugs"... I have a new thing happening, my microphone, stream deck and some USB stuff are disconnecting sometimes, they all turn off for few seconds and come back by themselves
 

ASK THE COMMUNITY