• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question black screen when installing my graphics card

Jul 24, 2021
3
0
10
0
I open my desktop for some cleaning when putting it back Im having very weird problem.

without my graphics card my pc boots normally
if I install my graphics card without placing the power cable in it (while the video output to the monitor is still connected to my mother board) it still boots normally.
but when I connect the power cable to the graphics card and the video output to the monitor is still connected to the motherboard I get a black screen, the keyboard and mouse light up but still a black scrern no response!
I have no idea whats happening this is a first for me.

specs:
cpu:I7-3770
motherboard: asrock z77 pro3
gpu: gigabyte 370 oc
power supply: corsair CX500
 
Jul 24, 2021
3
0
10
0
many motherboard's will disable any integrated GPU when a dedicated GPU is detected.

why do you want to use the iGPU instead?
I don't, I use the motherboard video output for use for troubleshooting after I'm done cleaning.
I tried placing the output in the video card and nothing either
 
Jul 24, 2021
3
0
10
0
many motherboard's will disable any integrated GPU when a dedicated GPU is detected.

why do you want to use the iGPU instead?
Actually I just tried it and it booted normally with the video output on the video card.
many motherboard's will disable any integrated GPU when a dedicated GPU is detected.

why do you want to use the iGPU instead?
Actually I just tried placing the video output on the GPU and it worked.
Im pretty sure I tried that before but idk.
+ my graphics card too some damage as the output image has 2 wide vertical lines where the color is not correct on each side.
I guess I must have messed something when cleaning it.
atleast its still usable :|
 

ASK THE COMMUNITY