Question Black screen with white squares on start up. Unsure as to why?

Oct 20, 2020
3
0
10
0
I don’t know why, but yesterday, while my pc was on in the background while downloading a steam game, the power supplywent mad and it sounded like the computer was about to take off. The screen turned black, although the power light was on, and became entirely unresponsive.

When I turned the computer back on, directly after the windows loading screen but before the log in screen the screen turns black with three white squares across the screen. The screen then flashes and turns black although the screen power light is still on as if it is receiving information, I am unable to interact with the computer in anyway at this point. If I leave the computer for a few mins the power supply goes mad again and the screen turns to stand by as it no information is being received.

I assume something has gone amiss with the GPU but I am unsure. I can turn the computer on in safe mode and have reinstalled GPU drivers but this has not fixed the problem. I have no idea how to approach this can anyone advise?

It runs on windows 10 and I have a AMD Radeon R290X series GPU. Please help.

UPDATE: I have discovered that the noise like the computer is about to take off is coming from the GPU’s fan and that when that begins, the GPU is really hot.
 
Last edited:
Oct 20, 2020
3
0
10
0
So I really do need the advice of someone with more technology knowledge than me here as I suspect this is going to be a £1000 + decision I make based upon that advice.

Update on actions taken. I have started up in safe mode and disabled the GPU. This allowed me to turn the computer on not in safe mode.

I subsequently uninstalled the drivers and attempted to reinstall. During the reinstall process the problem reappeared. About 51% of the way through the screen turns black with the power light saying it is still on. I leave it just encase this is just the drivers installing as flickering or temporarily black screens are normal during that.

A few minuets go by and the GPU cooling fan kicks into overdrive with the screen still black. A few seconds later and the screen turns off completely as if it has stopped receiving info from the GPU. I am forced to hard shut down the computer.

What is going on? Is this fixable?
 

ASK THE COMMUNITY