Question Black Screen

Jun 19, 2020
5
0
10
0
Im getting a black screen all my cables are good and well I reseated the gpu and ram sticks.The ez debug light was showing boot so I installed my hard drive on another computer to install it.I installed windows 10 and I still had a black screen so I install windows 7 and it worked but my keyboard and mouse was not working and the background had alot of pixels and it was kinda distorted please tell me what I can do to fix it. The Specs are
CPU - Ryzen 5 1600x
GPU - Msi Rx 570 4gb
Ram - 2x8 G.skill aegis
PSU- Corsair cx-m 450m (Semi Modular)
Hdd - Hitachi 1tb 7200 rpm
Mob - MSI B350 Gaming Plus

PC worked 6 months ago
 
Jun 19, 2020
5
0
10
0
I am getting a black screen my EZ Debug lights show cpu for 1 sec fans ramp-up then vga appears then disappears and the screen gets signal but black and fans are spinning and motherboard Led's are one I tested every component re-seated ram , gpu and I took a old gpu that i know works and it says the name of the graphics card in top right corner then black screen.I took my motherboard out of the case for easy access to parts I need help now because im thinking of buying a new motherboard.

CPU - Ryzen 5 1600x
GPU - Msi Rx 570 4gb
Ram - 2x8 G.skill aegis
PSU- Corsair cx-m 450m (Semi Modular)
Hdd - Hitachi 1tb 7200 rpm
Mob - MSI B350 Gaming Plus

PC worked 6 months ago
 
Jun 19, 2020
5
0
10
0
I am getting a black screen, my EZ Debug lights show cpu for 1 sec, fans ramp-up then vga appears then disappears and the screen gets signal but black, and fans are spinning and motherboard LEDs are on.

I tested every component re-seated ram , gpu and I took a old gpu that i know works and it says the name of the graphics card in top right corner then black screen.I took my motherboard out of the case for easy access to parts. I need help now because im thinking of buying a new motherboard.

CPU - Ryzen 5 1600x
GPU - Msi Rx 570 4gb
Ram - 2x8 G.skill aegis
PSU- Corsair cx-m 450m (Semi Modular)
Hdd - Hitachi 1tb 7200 rpm
Mob - MSI B350 Gaming Plus

PC worked 6 months ago
 

ASK THE COMMUNITY