Question Black screen

Sep 22, 2020
32
0
30
0
Hi, so I unplugged my psu from my first pc build to test another one, but when I put it back again I got black screen, everything's works fine like cpu, gpu etc, please help
 
Sep 22, 2020
32
0
30
0
Double-check both your 24-pin and 4 and/or 8-pin power connections from the PSU to the motherboard. Also, same for PCIe power connections to your GPU (assuming you are using such a config).
Everything is plugged right, I just unplug it and then plugged it back wth ?
 
Sep 22, 2020
32
0
30
0
Is your display/monitor connected directly to your GPU or to a video port attached to your motherboard?
Everything is like before, didn't change anything, and anyways at the first boot the pc turned on for 3 secs and kept restarting, then I disconnected the power cord and then here we go, black screen.
 

COLGeek

Cybernaut
Moderator
Disconnect power from the system. Then press the power button to discharge any residual power in the system.

Then, remove your memory and re-insert. Make sure memory is fully locked into the slots.

Try powering up again. Memory often gets dislodged slightly when messing with the motherboard power connectors, especially the 24-pin one.
 
Sep 22, 2020
32
0
30
0
Disconnect power from the system. Then press the power button to discharge any residual power in the system.

Then, remove your memory and re-insert. Make sure memory is fully locked into the slots.

Try powering up again. Memory often gets dislodged slightly when messing with the motherboard power connectors, especially the 24-pin one.
Omg, I cant tell how to thank you, one of ram slots we half connected and now everything's fine, again thank you.
 

ASK THE COMMUNITY

TRENDING THREADS