Question Blackbox Bluescreen crash only on certain games (Win 10)


Dec 1, 2012
So I have recently yet again encountered a black screen issue and am at wits end at this point trying to narrow it down. I used to have this issue when playing Star Citizen and narrowed that down to RAM issues which I ended up resolving by manually setting timings, voltage, and speed (my fault for using DOCP instead first) and staying on a bios that contains AGESA V2 PI Patch C; However the issue has started to crop up again months later for some reason, specifically whenever I play Resident Evil 4 Remake or Hell Let Loose, sometimes Valheim as well. I'm sure there's more I can add to the list but I'm to frustrated to test any other games trying to resolve this issue.

List of things tried so far:
-Driver update and rollback (With DDU obviously)
-Studio Drivers, Game Ready Drivers
-SFC, DISM, and Check Disk Scans
-Precision X1 closed and open
-Windows 10 Refresh

Specs are as follows:
CPU - AMD R9 3900XT (Stock settings)
RAM - G. Skill Trident Z F4-3600C16D-16GTZRC x2 (8gb x 4) (Slightly looser timings and lower speed for stability, closer to JEDEC Standard)
GPU - EVGA RTX 3070 FTW3 Ultra Gaming (Stock Settings)
PSU - Corsair RM850x (2021 Model I believe)

I'll post the WinDbg log below as well for any who are curious.


Dec 1, 2012
Loading Dump File [C:\Windows\Minidump\033023-12234-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

* Path validation summary **
Response Time (ms) Location
Deferred srv*
Symbol search path is: srv*
Executable search path is:
Windows 10 Kernel Version 19041 MP (24 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Edition build lab: 19041.1.amd64fre.vb_release.191206-1406
Machine Name:
Kernel base = 0xfffff8052f400000 PsLoadedModuleList = 0xfffff8053002a310
Debug session time: Thu Mar 30 16:47:29.217 2023 (UTC - 7:00)
System Uptime: 0 days 1:36:10.869
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
For analysis of this file, run !analyze -v
fffff8052f7fa110 48894c2408 mov qword ptr [rsp+8],rcx ss:0018:ffff870cb4bb0dc0=0000000000000050
9: kd> !analyze -v
  • *
  • Bugcheck Analysis *
  • *

Invalid system memory was referenced. This cannot be protected by try-except.
Typically the address is just plain bad or it is pointing at freed memory.
Arg1: ffffcb0146040000, memory referenced.
Arg2: 0000000000000002, X64: bit 0 set if the fault was due to a not-present PTE.
bit 1 is set if the fault was due to a write, clear if a read.
bit 3 is set if the processor decided the fault was due to a corrupted PTE.
bit 4 is set if the fault was due to attempted execute of a no-execute PTE.
- ARM64: bit 1 is set if the fault was due to a write, clear if a read.
bit 3 is set if the fault was due to attempted execute of a no-execute PTE.
Arg3: fffff8054ed5b7a6, If non-zero, the instruction address which referenced the bad memory
Arg4: 0000000000000000, (reserved)

Debugging Details:


Key : AV.Type
Value: Write

Key : Analysis.CPU.mSec
Value: 4233

Key : Analysis.DebugAnalysisManager
Value: Create

Key : Analysis.Elapsed.mSec
Value: 20472

Key : Analysis.IO.Other.Mb
Value: 2

Key : Analysis.IO.Read.Mb
Value: 0

Key : Analysis.IO.Write.Mb
Value: 6

Key : Analysis.Init.CPU.mSec
Value: 436

Key : Analysis.Init.Elapsed.mSec
Value: 3616

Key : Analysis.Memory.CommitPeak.Mb
Value: 94

Key : Bugcheck.Code.DumpHeader
Value: 0x50

Key : Bugcheck.Code.Register
Value: 0x50

Key : WER.OS.Branch
Value: vb_release

Key : WER.OS.Timestamp
Value: 2019-12-06T14:06:00Z

Key : WER.OS.Version
Value: 10.0.19041.1

FILE_IN_CAB: 033023-12234-01.dmp


BUGCHECK_P1: ffffcb0146040000


BUGCHECK_P3: fffff8054ed5b7a6


READ_ADDRESS: fffff805300fb390: Unable to get MiVisibleState
Unable to get NonPagedPoolStart
Unable to get NonPagedPoolEnd
Unable to get PagedPoolStart
Unable to get PagedPoolEnd
unable to get nt!MmSpecialPagesInUse




TRAP_FRAME: ffff870cb4bb1060 -- (.trap 0xffff870cb4bb1060)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ffffcb014603f000 rbx=0000000000000000 rcx=0000000000000400
rdx=000000000000f3ff rsi=0000000000000000 rdi=0000000000000000
rip=fffff8054ed5b7a6 rsp=ffff870cb4bb11f0 rbp=0000000000000000
r8=0000000000002614 r9=000000000000e012 r10=0000000000000000
r11=ffff870cb4bb1230 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei pl zr na po nc
fffff8054ed5b7a6 893488 mov dword ptr [rax+rcx*4],esi ds:ffffcb0146040000=????????
Resetting default scope

ffff870cb4bb0db8 fffff8052f87476f : 0000000000000050 ffffcb0146040000 0000000000000002 ffff870cb4bb1060 : nt!KeBugCheckEx
ffff870cb4bb0dc0 fffff8052f6a4d70 : 0000000000000005 0000000000000002 ffff870cb4bb10e0 0000000000000000 : nt!MiSystemFault+0x1b19cf
ffff870cb4bb0ec0 fffff8052f809bd8 : fffff8054097160d 0000000000000001 0000000000000000 0000000000000000 : nt!MmAccessFault+0x400
ffff870cb4bb1060 fffff8054ed5b7a6 : ffff8f048d40b0b0 0000000000000028 fffff8054ed8cf29 fffff8054ed50100 : nt!KiPageFault+0x358
ffff870cb4bb11f0 ffff8f048d40b0b0 : 0000000000000028 fffff8054ed8cf29 fffff8054ed50100 0000000000000080 : nvlddmkm+0x7fb7a6
ffff870cb4bb11f8 0000000000000028 : fffff8054ed8cf29 fffff8054ed50100 0000000000000080 000000000005a237 : 0xffff8f048d40b0b0 ffff870cb4bb1200 fffff8054ed8cf29 : fffff8054ed50100 0000000000000080 000000000005a237 0000000000000003 : 0x28 ffff870cb4bb1208 fffff8054ed50100 : 0000000000000080 000000000005a237 0000000000000003 000000000000000c : nvlddmkm+0x82cf29 ffff870cb4bb1210 0000000000000080 : 000000000005a237 0000000000000003 000000000000000c ffff8f048d40b003 : nvlddmkm+0x7f0100 ffff870cb4bb1218 000000000005a237 : 0000000000000003 000000000000000c ffff8f048d40b003 fffff8054f1aacc2 : 0x80 ffff870cb4bb1220 0000000000000003 : 000000000000000c ffff8f048d40b003 fffff8054f1aacc2 0000000000000001 : 0x5a237 ffff870cb4bb1228 000000000000000c : ffff8f048d40b003 fffff8054f1aacc2 0000000000000001 ffff8f048d40b0b0 : 0x3 ffff870cb4bb1230 ffff8f048d40b003 : fffff8054f1aacc2 0000000000000001 ffff8f048d40b0b0 0000000000000003 : 0xc ffff870cb4bb1238 fffff8054f1aacc2 : 0000000000000001 ffff8f048d40b0b0 0000000000000003 0000000000000000 : 0xffff8f048d40b003
ffff870cb4bb1240 0000000000000001 : ffff8f048d40b0b0 0000000000000003 0000000000000000 0000000000000000 : nvlddmkm+0xc4acc2
ffff870cb4bb1248 ffff8f048d40b0b0 : 0000000000000003 0000000000000000 0000000000000000 0000000000000000 : 0x1
ffff870cb4bb1250 0000000000000003 : 0000000000000000 0000000000000000 0000000000000000 0000000100000000 : 0xffff8f048d40b0b0 ffff870cb4bb1258 0000000000000000 : 0000000000000000 0000000000000000 0000000100000000 00000000`00000000 : 0x3

SYMBOL_NAME: nvlddmkm+7fb7a6

MODULE_NAME: nvlddmkm

IMAGE_NAME: nvlddmkm.sys

STACK_COMMAND: .cxr; .ecxr ; kb


FAILURE_BUCKET_ID: AV_W_(null)_nvlddmkm!unknown_function

OS_VERSION: 10.0.19041.1

BUILDLAB_STR: vb_release


OSNAME: Windows 10

FAILURE_ID_HASH: {838100fa-f28b-2ef7-d702-e31713cb338c}

Followup: MachineOwner


Dec 1, 2012
So just for archiving purposes anyone experiencing this same issue. The problem was not the DRAM, nor any BIOS settings. It was something simple, an extension cable. Specifically this one by Antec. The actual morale of the story here then is, only use your OEM cables, or buy replacements that are OEM to power your computer directly as cable extensions add too much resistance to provide proper power under full load. Extensive testing pointed to that being the issue, as DRAM was at stock non XMP/DOCP settings and the system would still crash, as well as a Underclocked card with a underclocked card. That also means potentially, that if you're able to pass benchmarking programs without issue (such as Heaven, Prime95, Y-Cruncher Classic and 2.5b) but crashes under load when playing a game and doing background work; Then the is almost certainly related to power delivery in some way. The few days of research conducted has taught me that voltages and resistances, are no joke.

If a moderator could close this thread I would greatly appreciate it as I solved it myself.
Last edited: