Question Blackscreen when putting game out of the tray

Aug 1, 2019
1
0
10
0
Recently I started having "blackscreens" (monitor says no signal), it always happens when I have a game running in the background and when I click the game to put it out of the tray suddenly my monitor goes blackscreen. When I am actually gaming it never happens, only when putting the game out of the tray, does not matter if the game is in fullscreen or windowed mode, tested with about 10 games, everytime blackscreen only happens when I am maximizing the game from tray. Computer stays running, all fans are operational, light on the graphic card is lightning like normally, but everything in computer stops, cant even hear any sound when the monitor loses the signal.

My PC is not overheating. Cannot be caused by harddrive since all games tested were on different harddrives. I have latest GPU drivers updated via Geforce Experience. I have tried to switch windows profile to "Performance mode", no difference. I have tried switching DVI/HDMI cables to my 3 monitors, no difference.


My Spec:
Intel Core i7 2600K
GTX 970 MSI gaming
16 GB DDR3 1666 Hz
750W PS (Replaced few months ago since I suspected the old one might be faulty)
Windows 7 Ultimate


Games tested:
Call of Duty WWII
Path of Exile
World of Tanks
Far Cry 4
Just Cause 3
Ghost Recon Wildlands
and few others I cant recall...




I have checked system event log, and there are no messages related to this problem at all, since I always have to reboot the computer manually, the only message there is that the windows system was shut down unexpectedly and thats it.


Could someone help me out where to start analyzing this problem please ? I have no idea where to search the origin on this issue, since event log is empty, nvidia itself does not have any logs.



Thanks in advance.
 

WaltzWorker

Reputable
Mar 18, 2015
156
15
4,715
10
Ugg! Remote troubleshooting bites lol Does this happen after a period of time, or immediately? Keyboard short cut for switching apps/programs is ALT+Tab (Hold ALT down and then tap on the TAB key and you'll see a 'menu' come up; hitting TAB again will change the highlighted app, release ALT and that app will become the program/app you'll be working on).
Have you tried re-seating all monitor connections? If you don't find any icons in the system tray/task bar going weird on you then I would suggest starting over... Power down the system and let it sit for 20 minutes. After that power up, then once the system is running immediately start a game and then minimize it. Then use your mouse or ALT+TAB method to bring it back. If you're able to do this then we'll have to continue down this line of a power/thermal/software issue. The reasoning for doing this is to allow all capacitors to fully discharge, allow the system to cool down.

OH!! While we're at it lets take a look at your virtual memory/page file/swap file settings. THIS VIDEO shows you how to change it, technically all we want to do is to see where it's at and see what the values are and report back please. It should be set to System Managed to the right of your OS drive (which is usually C). Please report back what the bottom says in the bottom: "Minimum allowed" "Recommended" and "Currently Allocated"
ONLY IF You Do Not have one: then please let Windows manage it by highlighting your OS drive (which is usually C) and then check the box at the top: "Automatically manage the page file for all drives" then click Okay, then that box closes, then click Apply, and that box closes and then restart. If you've allowed windows to manage the page file, then try it again - you should be able to minimize any program at anytime now... And the issue was that you didn't have enough virtual memory for windows to push the program you minimized to the taskbar/system tray to the swap file and Windows 'crashed'/'froze' although I would think it should have came up with a virtual memory box...

More of an FYI:
Here's one thing.... Once you've minimized the game to the system tray/task bar, wait a bit and move the mouse cursor over the icons. What your looking for is to see if any disappear, or they 'look funny' after the mouse has passed over them - apparently there have been issues with icons and such disappearing in the taskbar long time ago... There are a lot of posts everywhere about this one - an old issue but never know. Just out of curiosity have you started one game, minimized it to the tray, and then started another game in full screen? Try that and see how the taskbar/system tray responds...
 

ASK THE COMMUNITY

TRENDING THREADS