Question Blackscreen with fan loud noise

Oct 22, 2021
5
2
15
0
I am having the a problem with my GPU, the first month of buying it was everything okay and after that when I run specific games like State of decay 2 or Velheim the screen turns into black and the GPU fans ramp up like full speed %100. I tried to add cooling fan I thought that fixed the problem, I was able to play for 2 weeks or so, then the problem back again but worse. Now even when I am not running games or anything the screen sometimes turns into black and the fans start ramping up and sometimes it turns into black without even fan sounds. I really don't know what's the actual issue here :( . the parts of my PC is(GTX 770 2GB , Powersupply Aigo 650w . CPU I5 3470)
 
Oct 22, 2021
5
2
15
0
the GPU used, also the temperatures of the CPU (Value : 37c at min and 48 at max) . as for GPU ( min is 34c and max 39c). I am not running any game or anything currently. Only steam and discord and google. So what do you think about it D: ?
 
Well the only thing that changed with your pc is the gpu. So I would hazard a guess and say you have a gpu problem. Now we have to figure out if it is a driver/file problem or actual hardware problem. First step in troubleshooting would be to run sfc /scannow to check your windows files. Then download ddu uninstaller and erase all Nvidia driver files. Official Display Driver Uninstaller DDU Download (wagnardsoft.com) After you uninstall the drivers go to device manager, display adapter, click on the gtx 770 and let windows install the driver for now. Then check to see if the problem persists. If it does then you will have to look at the gpu itself. Depending on your level of working with gpu's you may want to open the card and check the thermal paste on the gpus cpu. Also what motherboard do you have?
 
Oct 22, 2021
5
2
15
0
I am gonna place new thermal paste today for the gpu to see if it will work, cuz yesterday while playing games everytime I play it last 5-mins then I start getting black screen with noise GPU sound. also my mother board gen2/3 Gigabyte GA-H61M-S2P
 
Oct 22, 2021
5
2
15
0
I fixed the issue today. It was the thermal paste. The expert changed the thermal paste and put it on the GPU, also he downloaded new software for the card. Before when I play heavy games the temps was always 80-81c, but now it's only 60c after I changed the thermal paste and download new software. for now no blackscreen, no lags while playing. I will let you know if something happen and thank you for your support :)
 
I fixed the issue today. It was the thermal paste. The expert changed the thermal paste and put it on the GPU, also he downloaded new software for the card. Before when I play heavy games the temps was always 80-81c, but now it's only 60c after I changed the thermal paste and download new software. for now no blackscreen, no lags while playing. I will let you know if something happen and thank you for your support :)
Glad to hear it.(y)
 
Reactions: Neliel2000

ASK THE COMMUNITY

TRENDING THREADS