Sep 22, 2021
2
0
10
0
I am trying to enable Secure Boot on my PC, however, when I disable CSM, I get a black screen whenever I boot into my BIOS. My OS is installed in UEFI mode, so being blocked by legacy BIOS isn't the issue. I need to disable CSM so I can enable Secure Boot for some applications to work in Windows 11.

I have already tried restarting resetting the CMOS and reinstalling the battery, but in both cases when I retry the steps to disable the CSM, the same issue reappears.

Does anyone know what I can do here without a full wipe and reinstall of Windows?

Relevant System Info:
MB: ASRock X570 Pro4
  • fTPM enabled
  • XMP enabled (3200 mHz)
  • CSM disabled
  • Secure Boot disabled
CPU: Ryzen 5 3600
Boot Drive: Inland Premium 1TB SSD
GPU: GIGABYTE GeForce GTX 1080 8GB
Windows installed in UEFI mode
 

ASK THE COMMUNITY

TRENDING THREADS