Blank screen after installing second RAM and SSD

Oct 7, 2018
2
0
10
0
So I built my new pc last week and it’s been running like a charm, but I waited to upgrade the RAM and install a SSD until I had the money.

After installing the second identical RAM, and SSD without hardly touching anything else, I got a blank screen and the keyboard and mouse won’t turn on. All fans and lights are running.

I’ve tried each memory stick in each slot by itself and even disconnecting the new SSD but now it won’t even work when everything is how it was. I also made sure everything is still plugged in and even tried reseating the video card as that was the case last time. I also took the CMOS battery out and back in.

I’ll post my specs below:

AMD Ryzen 5 1600 CPU

MSI B350M Gaming Pro Micro ATX AM4 Motherboard


G. Skill Aegis 16GB (2x8) DDR4 3000 RAM

Seagate Barracuda 1TB 3.5" 7200RPM Hard Drive

Samsung 860 Evo 1TB 2.5" SSD

PowerColor Radeon RX 580 8GB Red Devil Video Card

Corsair CXM 2015 450W 80+ Bronze Certified Semi-Modular ATX Power Supply

Any help at all would be greatly appreciated. I just want to use my build again :(

UPDATE: I realize I should probably be replying to this thread instead of leaving answers but I’m stuck on mobile hence my pc not working and cannot figure out how to reply to answers.

Something strange is happening with my pc, I will leave a video below showing the state of my pc.

My motherboard does not have integrated audio therefore it does not give the POST beeps when turning on. It does however have what it calls an EZ Debug LED.

https://vimeo.com/294009821

As you can see, all fans are running as well as the graphics card, but none of the USB ports are being powered and the monitor still says no signal when plugged into the graphics card.

Pressing the power button will turn on the pc, but pressing it again will have no effect except when holding it down which will power it off. BUT the restart button on the other hand signals the EZ Debug LED to flash a couple of lights and then turn off again, but the computer itself will not actually restart. When the restart button is pressed you can hear the fans quiet down for a second but then immediately go back to normal speed.

If anyone knows what the flashing led pattern means or what could possibly be the problem please let me know! Thanks!
 
Oct 7, 2018
2
0
10
0
I am happy to report from my up and running pc! It was a simple CMOS Reset but now you can catch it in my attempted solutions that I did not unplug my pc when I removed the CMOS Battery and this time also made sure to hold the power button for good luck!

I will start a new thread if installing the second RAM creates a new problem. Thanks for your help julienruc!
 

Similar threads


ASK THE COMMUNITY