Question Blank Screen (LED on) after BIOS Screen

Jul 17, 2021
7
0
10
0
Yesterday, I could still use my PC just fine but after booting up today it just goes blank after the BIOS screen. The monitor works just fine without any problem. I don't remember doing any updates yesterday but I had one two days ago. I tried forcing my PC to go on automatic repair by restarting it several times but the screen is still blank.

My processor is an AMD A10 7860K
My mobo is MSI A68HM - E33 V2
 
Jul 14, 2021
8
1
25
2
Yesterday, I could still use my PC just fine but after booting up today it just goes blank after the BIOS screen. The monitor works just fine without any problem. I don't remember doing any updates yesterday but I had one two days ago. I tried forcing my PC to go on automatic repair by restarting it several times but the screen is still blank.

My processor is an AMD A10 7860K
My mobo is MSI A68HM - E33 V2
Sounds like something is wrong with your graphics card. Assuming this is a desktop, check to make sure that it didn't come loose and the port isn't damaged. Also unplug your monitor from the desktop and then plug it back in.
 
Jul 17, 2021
7
0
10
0
Sounds like something is wrong with your graphics card. Assuming this is a desktop, check to make sure that it didn't come loose and the port isn't damaged. Also unplug your monitor from the desktop and then plug it back in.
I tried switching to my Integrated Graphics Card and an old GPU, 2GB GT 730, but it is still the same. I tried to unplug and replug everything. The ports and cables are fine.
 
Jul 17, 2021
7
0
10
0
so only the gpu turn off right?
I don't exactly know but I seem to be able to switch to my integrated graphics card and a dedicated gpu but the problem is still there. It can't be that both are damaged at the same time? The screen is still on but just a black light.
 

ASK THE COMMUNITY

TRENDING THREADS