Blue screen after having added some RAM

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0
Hey there,

I bought some RAM today (Ballistix Tactical DDR3 1600Mhz 2x8GB) and after I put them inside my I keep getting a bluescreen. Either instantly or after a while. I'm clueless what to do to fix this problem.

Also got Ballistix DDR3 1600Mhz 2x4GB inside my pc.

Thanks in advance.
 

LilTwist

Reputable
Mar 28, 2014
772
0
5,160
84
what is your motherboard? if it is something cheap then you might be exceeding your ram capacity. if you have 4 sticks in it make sure to have 8gb then 4bg then 8gb then 4gb isntead of having the 2 4gb next to eachother and the 2 8gb next to eachother
 
Ideally you would of bought the exact make and model of RAM. If not, you need to manually adjust the timings and voltage in the bios to match. Even then you may have issues though, and that is why it's generally recommended to buy RAM in kits. Have you tried pulling out the 2x4gb sticks? That may be your only option for now.

PS: LilTwist is right. It is possible that the max ram your board can support is 16gb as well.
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


My motherboard = ASUS B85M-G
In the manual it says it should support up to 32GB RAM and yes I put them in the way you said.

Thanks for the answer
 

LilTwist

Reputable
Mar 28, 2014
772
0
5,160
84
also just stick with the 2x8Gb sticks thats 16Gb really there is no reason to have more than 8Gb of ram but its a personal reference I guess try taking out the 2 4gb sticks and leave the 8gb sticks where they are and see if that works
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


Yeah I'm not really a PC expert as you might have noticed, I was looking on the internet on what to buy. Some people claimed I had to have the same type of RAM module, others claimed it shouldn't make a difference so I just bought a pair. How can I adjust the timings and voltage in my Bios?
Yeah I took out the 2x4GB and it worked for a while. Then I decided to put in the 2x4GB back in again in the way that Liltwist said and it worked fine aswell for like an hour or 2. Then another blue screen popped up.

Thanks for the answer!
 
I'm guessing a timing and voltage issue like I mentioned above. What are the timings and voltages for each kit? There should be a little sticker on each ram stick listing the timings and voltage. EXAMPLE: 9-9-9-35 1.5v
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


Yeah I guess you are right, I might do that anyway. Was just wondering if it was able to get the 2x4GB working as well since I got them anyway haha
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


The 2x4GB says: 1600Mhz 9-9-9-24 1.35V
The 2x8GB says: 1600Mhz 8-8-8-24 1.5V
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


I got a 700W power supply, I THINK it is enough. If that's the problem let me know though (I know a bit about computers but not that much as you must have noticed)
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


Thanks for helping me Liltwist apreciate it,

I wouldn't know how to configure the voltage and speed in my BIOS though, is it easy to do?
 


Definitely the timings and voltage then. Under advanced memory tab in the bios you will need to change some settings. Here is a guide, and hopefully it works out for you: http://overclock3d.net/articles/memory/how_to_manually_set_up_your_ram_speed_timings_and_voltage/1
 

LilTwist

Reputable
Mar 28, 2014
772
0
5,160
84
you could do what sincreator said to do if you actually want all that ram but personally I would just sell the 2 4gb sticks as a kit and hang with the 16Gb 2x8Gb ram if it works after you take out the smaller ram
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


I'm just gonna take the 2x4GB out because I don't wanna fuck anything up lol. I really wanna thank you for your help I really apreciate it man!

 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


Yeah I'm gonna take the 2x4GB out. 16GB should be enough anyway haha.
Thanks a lot for your help, really apreciate it!
 


No problem. Anytime! :)
 

koudevoet

Reputable
Jan 27, 2015
10
0
4,510
0


Have been on my pc for a while now with "just" the 16GB RAM in it, and no blue screens yet.

Thanks both of you!
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS