Ellioot

Reputable
Aug 3, 2016
5
0
4,510
0
Hello,

I built my PC in the summer of 2016, I have never had any issues regarding memory, cpu or GPU. The PC has remained relatively untouched since I built it with the regular cleaning of dust. Today when I logged on to my computer, I was getting the blue screen of death (BSOD) a couple minutes into loading the desktop with the stop code being: PAGE_FAULT_IN_NONPAGED_AREA (cpuz141_x64.sys). I had a look at differnt articles and tutorials in how to resolve it (removing CAM software, uninstall latest quality updates, changing page limit). All of these didn't seem to work and within 2 minutes of logging in I would get the infamous blue screen.

Struggling what I should do, I saw somewhere that just taking the RAM out might be help. So I did, ensuring that the whole system was turned off and unplugged, I popped my one stick of corsair 8gb ram out and inspected it, no dust, no issues (this is probably the first time I have taken it out since I installed it). Not thinking much of it, i installed it back and I knew it was installed proerly with the satisfying click of the teeth securing the position. The computer then did not boot, no signal was coming through to the monitor. (Led lights, fans and cooler LED all came on however).

I then tried different RAM ports and still had no luck. To add the DRAM_LED light now is a bold red, does not flash (unless I press the reset button temporarily). I know this light indicates a memory issue although I am not sure whats the issue. I dont have another ram stick to test if its a faulty or damanged ram. I am now wondering what my issue could be, I have not moved the computer in the last 4 months and it has been running just fine since I've had it. I'm only a uni student and don't currently have the monetary funds to splash on a stick of ram (any good cheap rams let me know!)

I would love any help or suggestions in what I should do, I understand getting a RAM replacement could help, but just want to eliminate any other issues which could be causing this before buying anything. I pressume the BSOD and the DRAM_LED are probably correalted someway.

Thanks a lot!

Elliot

CPU SPECS (if I remember),
-CPU : I5 4690K
-GPU: Windforce Nvidia GTX 960
-Motherboard: ASUS Z97 Sabertooth Mark S
RAM: 1x8gb Corsair DDR3
SSD: HyperX 120gb SSD
HDD: WD Blue 1TB
Cooler: NZXT kraken x41
Windows 10
 

ASK THE COMMUNITY