• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Bluetooth acting weird, not recognizing audio device

May 14, 2020
1
0
10
0
Windows 10 Pro, Intel Core i5-2500K, 16GB RAM

Have tried Avantree BTDG-40S and TechKey USB Bluetooth dongles

I'm trying to connect my Sony WH-1000XM3 headphones to my desktop. They successfully pair and work with both my Surface and my Moto G4 Plus phone, and the firmware is up to date.

The first problem I had was using the TechKey dongle, the headphones would successfully pair with the computer, but would not be recognized as an audio device, but would instead be classified as a generic device and not show up in audio settings. No good. I fiddled with the drivers, but they were up to date. Going into the Device Manager, LE_WH-1000XM3 would appear under Bluetooth, but all of the info pointed to it being a generic device. I went through as many troubleshooting steps as I could find, including restarting the Bluetooth services at various points in the pairing process, but nothing. I figured it was a problem with the dongle, so I got a new one.

Enter the Avantree BTDG-40S. First, it wasn't getting recognized by the Plug-and-Play service. Not sure how, but it got, like, halfway installed three times as I insert it/removed it. I cleared the phantom USB devices out, restarted, and it self-installed. But the results in the Bluetooth screen were even worse. Before, the settings screen had been doing this weird thing where it would self-minimize every time it connected to the headphones. Weird flex but ok. Now it's minimizing everytime it detects the headphones in the device pairing screen. Additionally, looking at the device manager during this process, a device called WH-1000XM3 is showing up as soon as I start the device detection process--before I've paired anything. Super weird.

Despite all that, the first time I tried to pair, it showed LE_WH-1000XM3 as an audio device! But it was a trick. It would successfully pair, but when I went to the device and hit Connect, it would instantly give a "couldn't connect" error (tried this with the headphones both in pairing mode and idle mode). Oky, disconnect the device, try to repair. Now it's showing up, but as a generic device again!

None of this makes sense. Any insights as to what the hell might be going on?
 

ASK THE COMMUNITY

TRENDING THREADS