Question Bluetooth seems to be blocked by case

Jul 18, 2020
2
0
10
0
I tried connecting a bluetooth xbox controller to my computer the other day, but I've been having some trouble. I have an Asus X299 Prime edition 30 motherboard, so it has bluetooth and everything on board, but when i tried to connect, I couldn't get the controller to appear in the connection list. Eventually I found that it would recognize it and connect if I moved the controller to the opposite site of the case, where the glass is, but then lost connection when I brought the controller back up over the top or other side of the case. Seems kindof ridiculous for the bluetooth signal to be blocked when I'm less than 2 feet away.

I found a thread on here that suggested the problem could be fixed by connecting the wifi antenna to the two metal plugs on the back, so I tried it but still no luck. In fact now I can't even get it to connect when I put move it to the other side of the case like before. Wifi is working great though so I'm not sure whats going on. Any ideas or help would be greatly appreciated!

Thanks!

Edit:
Sytem Hardware and specs are:

Asus X299 Prime Edition 30 Motherboard
intel Core i9 9940x
Gskill Trident Z neo 128GB RAM
EVGA 2080ti black edition
Samsung 1TB EVO Plus nvme ssd
Windows 10 Pro x64 v1909
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS.

Make and model Bluetooth xbox controller? Have you tried downloading, reinstalling, and reconfiguring the applicable drivers via the manufacturer's website?

How many USB devices are connected?

When you state that you could not get the controller to appear in the connection list do you mean Device Manager? Double check that "Show hidden devices" is checked via the View tab in Device Manager.
 
Jul 18, 2020
2
0
10
0
Ok I updated my post to include system specs!

The controller I'm using is the Xbox Elite Series 2. I have tried reinstalling the bluetooth drivers from the motherboard support page a couple times, but it just displays a cmd window for a split second so its hard to see what its doing. The screenshots Ive managed to grab seem to indicate that it is being installed properly.

As far as usb devices go, I have 3 external harddrives plugged in, as well as a usb3.0 hub that I have my mouse and keyboard plugged into. Also my monitor has a usb hub attached to it so its plugged in as well, but nothing is connected to it.

lastly I wasn't talking about device manager unfortunately, I was referring to the "Bluetooth & other devices" menu in Settings. I clicked on the "+" next to "Add Bluetooth or other device", and then next on the "Bluetooth" button, after which I hold the connect button on top of the controller to get it into discovery mode, but the computer just keeps searching constantly for bluetooth devices without finding any. :/

I hope that answers all your questions, let me know if there's any other information that might be helpful!

Thanks again for any help you can give!
 

ASK THE COMMUNITY