Bluetooth Suddenly Stopped Working On Windows 10 PC

Nov 1, 2018
2
0
10
0
Hi all. I'm using an Avantree bluetooth dongle for my PC build. My mobo is an ASUS Maximus 7 GENE and does not have built in bluetooth. I use bluetooth to connect my BT headphones, Logitech BT speakers, and XBox One Wireless Controller to my computer. Lately, probably due to a Win 10 update, my peripherals started malfunctioning. It started with me losing connection to my headphones. I tried removing the device and re-adding it but it won't work. Until I switched the dongle to a different USB port then my headphones started working again. I thought everything was fine until I noticed that both my controller and speakers have stopped working too. I tried removing ALL three devices and re-adding them. Yet until now, I have had no success. I've shifted the dongle to different USB ports, even tried downloading a driver for my Avantree BT dongle, also drivers for the CSR8510A10 since that's the name of the Avantree Dongle when I view it in Devices. None of the things I tried work. I don't want to reformat yet. I have so much going on right now to reformat my PC. Yet not being able to hear sound from my PC via BT is killing me. Any solution will be much appreciated. Thank you in advance.
 

viveknayyar007

Splendid
Moderator
Hello archie.luna.bm

Can you please try uninstalling the most recent Windows update(s) after which the dongle stopped working? This is merely to check if any of the installed updates is conflicting with the BT driver.

Please report back with the results to allow us to help you with a solution.

Cheers!! :)
 
Nov 1, 2018
2
0
10
0


Ok, will try and get back to you.

Update: I was only able to uninstall KB4100347 and partially uninstall KB4462933. Anything beyond that won't uninstall. Anyway, It seems to have done nothing. I am still on the same Generic Bluetooth drivers dated 2006. I have exhausted all the tips online yet have come up with nothing. The 3 devices are discoverable but they would not pair. They used to be paired, but since I read a lot of suggestions of unparing them and then re-pairing, I unpaired them. When I tried re-pairing them, they won't any more. I just can't do a clean installation right now.
 

ASK THE COMMUNITY

TRENDING THREADS