• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question Board not booting with 1600MHz DDR3 ram


Jun 18, 2015
I have a GA-B85-HD3 rev-2.1 with 2 HX318C10F/8 Kingston Hyper Fury. It has been working for over ~3 years.
A couple of weeks ago, it stopped posting with Ram sound.
Current symptoms:
  • Booting with Ram either single module, double or no ram at all creates the same sound issue.
  • Testing more rams indicated that the board only boots now with 1333 MHz (PC3-10600) but not 1600MHz.
  • I tried to flash bios (solved it once for 6 months or more when it first happened), I tried F1, F2 and F4 and all had the same.
  • Ram works on other boards but not that board.
  • Other 1600MHz ram don't work.
  • Putting one 1333 with 1 1600 but not the Kingston (other brand that doesn't have OC) it works. The Kingston one doesn't.
  • I booted with 1333 and set the frequency to 1333 or 800, then put the other 1600 with the 1333 and validated the low frequency of 800MHz, then remove the 1333, it doesn't boot. It seems that the processor still tries to figure out the max or the nominal while posting.
Any idea what would be the possible cause of this and whether it can be fixed or no other alternative but to buy either a new Ram or new Board?